[an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] Install Prerequisites
Gold User's Guide
<<< Previous Installation Next >>>

Install Prerequisites

You will first need to build, test and install the following prerequisites:

PostgreSQL database 7.2 or higher (or other tested database) [REQUIRED]

Gold makes use of a database for transactions and data persistence. Three databases have been tested for use with Gold thus far: PostgreSQL, MySQL and SQLite (see Select a Database). If you intend to use the PostgreSQL or the MySQL database, you will need to install it. PostgreSQL is recommended since it is an excellent database, has been more thoroughly tested than the others, and supports the most features. PostgreSQL is available at: <http://www.postgresql.org/>

[root]# cd /usr/local/src

[root]# wget http://ftp7.us.postgresql.org/pub/postgresql//source/v8.3.3/postgresql-8.3.3.tar.gz

[root]# gzip -cd postgresql-8.3.3.tar.gz | tar -xvf -

[root]# cd postgresql-8.3.3

[root]# ./configure

[root]# make

[root]# make install

[root]# adduser postgres

[root]# mkdir /usr/local/pgsql/data

[root]# chown postgres /usr/local/pgsql/data

[root]# touch /var/log/pgsql

[root]# chown postgres /var/log/pgsql

Or if you are using rpms, you will need the postgresql, postgresql-libs, postgresql-server, and postgresql-devel rpms appropriate for your architecture and operating system:

[root]# wget ftp://rpmfind.speakeasy.net/linux/redhat/updates/9/en/os/i386/postgresql-7.3.2-3.i386.rpm

[root]# wget ftp://rpmfind.speakeasy.net/linux/redhat/updates/9/en/os/i386/postgresql-libs-7.3.2-3.i386.rpm

[root]# wget ftp://rpmfind.speakeasy.net/linux/redhat/updates/9/en/os/i386/postgresql-server-7.3.2-3.i386.rpm

[root]# wget ftp://rpmfind.speakeasy.net/linux/redhat/updates/9/en/os/i386/postgresql-devel-7.3.2-3.i386.rpm

[root]# rpm -Uvh postgresql-7.3.2-3.i386.rpm postgresql-libs-7.3.2-3.i386.rpm postgresql-server-7.3.2-3.i386.rpm postgresql-devel-7.3.2-3.i386.rpm

Perl 5.6.1 or higher (with suidperl) [REQUIRED]

The Gold server and clients are written in Perl. Perl 5.6.1 or higher is required. The perl installation must include suidperl for proper client authentication. Use 'perl -v' to see what level of Perl is installed and 'suidperl -v' to see if suidperl is installed. Perl is available at: <http://www.perl.com/>

[root]# cd /usr/local/src

[root]# wget http://www.cpan.org/src/perl-5.10.0.tar.gz

[root]# gzip -cd perl-5.10.0.tar.gz | tar xvf -

[root]# cd perl-5.10.0

[root]# sh Configure -Dd_dosuid -de

[root]# make

[root]# make test

[root]# make install

[root]# (cd /usr/include && /usr/local/bin/h2ph *.h sys/*.h)

Or if you are using rpms, you will need the perl and the perl-suidperl rpms appropriate for your architecture and operating system:

[root]# wget ftp://rpmfind.speakeasy.net/linux/redhat/updates/9/en/os/i386/perl-5.8.3-18.1.i386.rpm

[root]# wget ftp://rpmfind.speakeasy.net/linux/redhat/updates/9/en/os/i386/perl-suidperl-5.8.3-18.1.i386.rpm

[root]# rpm -Uvh perl-5.8.3-18.1.i386.rpm perl-suidperl-5.8.3-18.1.i386.rpm

libxml2 2.4.25 or higher [REQUIRED]

LibXML2 is needed by the XML::LibXML perl module to communicate via the SSSRMAP message format. LibXML2 is available at: <http://www.xmlsoft.org/>

[root]# cd /usr/local/src

[root]# wget —passive-ftp ftp://xmlsoft.org/libxml2/libxml2-2.6.32.tar.gz

[root]# gzip -cd libxml2-2.6.32.tar.gz | tar xvf -

[root]# cd libxml2-2.6.32

[root]# ./configure

[root]# make

[root]# make install

Gnu readline 2.0 or higher [OPTIONAL]

The interactive control program (goldsh) can support command-line-editing capabilities if readline support is enabled. Most recent linux distributions come with the appropriate readline support. Gnu readline is available at: <http://www.gnu.org/>

[root]# cd /usr/local/src

[root]# wget http://ftp.gnu.org/gnu/readline/readline-5.0.tar.gz

[root]# gzip -cd readline-5.0.tar.gz | tar xvf -

[root]# cd readline-5.0

[root]# ./configure

[root]# make

[root]# make install

Apache Httpd Server 2.0 or higher [OPTIONAL]

Gold provides a web based GUI so that managers, users, and administrators can interact with the accounting and allocation system. The web interface utilizes Perl CGI and SSL and needs to have an httpd server (preferably apache) installed. Apache httpd is available at: <http://httpd.apache.org/>

[root]# cd /usr/local/src

wget http://rpm.emsl.pnl.gov/3.0AW/en/os/i386-U4/RedHat/RPMS/httpd-2.0.46-44.ent.i386.rpm

[root]# rpm -Uvh httpd-2.0.46-44.ent.i386.rpm

OpenSSL 0.9.5a or higher [OPTIONAL]

If you are installing the GUI you will need SSL (preferably OpenSSL). OpenSSL is a command line toolkit for using secure socket layer encryption on a server. OpenSSL is available at: <http://www.openssl.org/>

[root]# cd /usr/local/src

wget http://rpm.emsl.pnl.gov/3.0AW/en/os/i386-U4/RedHat/RPMS/openssl-0.9.7a-33.12.i386.rpm

[root]# rpm -Uvh openssl-0.9.7a-33.12.i386.rpm

mod_ssl 2.26 or higher [OPTIONAL]

If you are installing the GUI you will need an apache interface to OpenSSL (preferably mod_ssl). There are other alternatives to mod_ssl (one of which is apache-ssl from which the mod_ssl code was forked), however mod_ssl has become the defacto standard and is the most widely adopted. mod_ssl is available at: <http://www.modssl.org/>

[root]# cd /usr/local/srcwget http://rpm.emsl.pnl.gov/3.0AW/en/os/i386-U4/RedHat/RPMS/mod_ssl-2.0.46-44.ent.i386.rpm

[root]# rpm -Uvh mod_ssl-2.0.46-44.ent.i386.rpm

<<< Previous Home Next >>>
Installation Up Configuration
[an error occurred while processing this directive] [an error occurred while processing this directive]