[torqueusers] torque4 and MPSS3

Taras Shapovalov taras.shapovalov at brightcomputing.com
Mon Mar 10 03:32:02 MDT 2014


Hi David,

Thanks you for the explanation. I don't still see the whole picture. Do I
understand correctly that there are actually two issues?

1. "COIPipeline_source.h not found" and thus TORQUE will not have a full
support of MPSS. It would be nice to know what "full support" really means
here.

2. Some low level api headers are not installed (and no way to download
them without a special request to Intel). I wonder why it is not the case
for MPSS2 and why there is no any information about llapi in MPSS3. Do you
know if it is not officially released yet (sort of a beta version for now)?

Best regards,
Taras



On Thu, Mar 6, 2014 at 8:07 PM, David Beer <dbeer at adaptivecomputing.com>wrote:

> It makes calls to read information from the Xeon Phi card through those
> headers, so that's why it has to check for their presence. These headers
> are a requirement for using the full Xeon Phi support from TORQUE.
>
>
> On Thu, Mar 6, 2014 at 3:23 AM, Taras Shapovalov <
> taras.shapovalov at brightcomputing.com> wrote:
>
>> Hi David,
>>
>> No, I don't have llapi headers on my system. Why it checks source/COIPipeline_source.h
>> then?
>>
>> Best regards,
>> Taras
>>
>>
>> On Wed, Mar 5, 2014 at 8:44 PM, David Beer <dbeer at adaptivecomputing.com>wrote:
>>
>>> The LLAPI headers that TORQUE is searching for are for the lower level
>>> API. Do you have these headers on your system? If so, what directory are
>>> they found in?
>>>
>>>
>>> On Wed, Mar 5, 2014 at 12:20 AM, Taras Shapovalov <
>>> taras.shapovalov at brightcomputing.com> wrote:
>>>
>>>> Hi David,
>>>>
>>>> I am using official packages available here:
>>>>
>>>>
>>>> http://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss
>>>>
>>>> Why I need to use something else for MPSS3? Frankly I am quite
>>>> surprised by your question, because with MPSS2 torque4 works pretty well
>>>> without any "low level api libraries".
>>>>
>>>> In any case, I see the problem is pretty clear: even if the header file
>>>> exists, the configure script searches the file in different place. So,
>>>> simplifying, --with-mic-path option is broken.
>>>>
>>>> Best regards,
>>>> Taras
>>>>
>>>>
>>>> On Tue, Mar 4, 2014 at 8:14 PM, David Beer <dbeer at adaptivecomputing.com
>>>> > wrote:
>>>>
>>>>> Taras,
>>>>>
>>>>> Do you have the lower-level API library? If I remember correctly Intel
>>>>> doesn't give it to you by default, you have to request it. We've had a
>>>>> number of customers with this issue.
>>>>>
>>>>> David
>>>>> On Mar 4, 2014 12:00 AM, "Taras Shapovalov" <
>>>>> taras.shapovalov at brightcomputing.com> wrote:
>>>>>
>>>>>> Hi David,
>>>>>>
>>>>>> The problem as I mentioned is in built-in (wrong) paths in the
>>>>>> configure script (and maybe somewhere else).
>>>>>>
>>>>>> $ ./configure --enable-mic
>>>>>> ...
>>>>>> checking whether to compile with MIC support... yes
>>>>>> checking source/COIPipeline_source.h usability... no
>>>>>> checking source/COIPipeline_source.h presence... no
>>>>>> checking for source/COIPipeline_source.h... no
>>>>>> configure: error: MIC COI LLAPI headers not found
>>>>>>
>>>>>> $ ls /usr/include/intel-coi/source/COIPipeline_source.h
>>>>>> /usr/include/intel-coi/source/COIPipeline_source.h
>>>>>>
>>>>>> $ ./configure --enable-mic --with-mic-path=/usr/include/intel-coi
>>>>>> ...
>>>>>> checking whether to compile with MIC support... yes
>>>>>> checking source/COIPipeline_source.h usability... no
>>>>>>  checking source/COIPipeline_source.h presence... no
>>>>>> checking for source/COIPipeline_source.h... no
>>>>>> configure: error: MIC COI LLAPI headers not found
>>>>>>
>>>>>> Best regards,
>>>>>> Taras
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Fri, Feb 28, 2014 at 10:01 PM, David Beer <
>>>>>> dbeer at adaptivecomputing.com> wrote:
>>>>>>
>>>>>>> Taras,
>>>>>>>
>>>>>>> Can you share the exact error that you're getting with this? We like
>>>>>>> to fix these kind of things :-)
>>>>>>>
>>>>>>>
>>>>>>> On Fri, Feb 28, 2014 at 9:03 AM, Taras Shapovalov <
>>>>>>> taras.shapovalov at brightcomputing.com> wrote:
>>>>>>>
>>>>>>>> Hi guys,
>>>>>>>>
>>>>>>>> Has anybody built torque 4.2.6.1 with Xeon Phi support (the latest
>>>>>>>> MPSS version now is MPSS3)? Looks like ./configure uses built-in paths to
>>>>>>>> coi directory that do not exist in the latest MPSS.
>>>>>>>>
>>>>>>>> I wonder if somebody of you has just hacked the script and are
>>>>>>>> using torque with MPSS3 successfully.
>>>>>>>>
>>>>>>>> Thanks,
>>>>>>>> Taras
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> torqueusers mailing list
>>>>>>>> torqueusers at supercluster.org
>>>>>>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> David Beer | Senior Software Engineer
>>>>>>> Adaptive Computing
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> torqueusers mailing list
>>>>>>> torqueusers at supercluster.org
>>>>>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>>>>>
>>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> torqueusers mailing list
>>>>>> torqueusers at supercluster.org
>>>>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>>>>
>>>>>>
>>>>> _______________________________________________
>>>>> torqueusers mailing list
>>>>> torqueusers at supercluster.org
>>>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>>>
>>>>>
>>>>
>>>> _______________________________________________
>>>> torqueusers mailing list
>>>> torqueusers at supercluster.org
>>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>>
>>>>
>>>
>>>
>>> --
>>> David Beer | Senior Software Engineer
>>> Adaptive Computing
>>>
>>> _______________________________________________
>>> torqueusers mailing list
>>> torqueusers at supercluster.org
>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>
>>>
>>
>> _______________________________________________
>> torqueusers mailing list
>> torqueusers at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>
>>
>
>
> --
> David Beer | Senior Software Engineer
> Adaptive Computing
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20140310/4446aa5e/attachment-0001.html 


More information about the torqueusers mailing list