[torqueusers] torque4 and MPSS3

Taras Shapovalov taras.shapovalov at brightcomputing.com
Wed Mar 5 00:20:50 MST 2014


Hi David,

I am using official packages available here:

http://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss

Why I need to use something else for MPSS3? Frankly I am quite surprised by
your question, because with MPSS2 torque4 works pretty well without any
"low level api libraries".

In any case, I see the problem is pretty clear: even if the header file
exists, the configure script searches the file in different place. So,
simplifying, --with-mic-path option is broken.

Best regards,
Taras


On Tue, Mar 4, 2014 at 8:14 PM, David Beer <dbeer at adaptivecomputing.com>wrote:

> Taras,
>
> Do you have the lower-level API library? If I remember correctly Intel
> doesn't give it to you by default, you have to request it. We've had a
> number of customers with this issue.
>
> David
> On Mar 4, 2014 12:00 AM, "Taras Shapovalov" <
> taras.shapovalov at brightcomputing.com> wrote:
>
>> Hi David,
>>
>> The problem as I mentioned is in built-in (wrong) paths in the configure
>> script (and maybe somewhere else).
>>
>> $ ./configure --enable-mic
>> ...
>> checking whether to compile with MIC support... yes
>> checking source/COIPipeline_source.h usability... no
>> checking source/COIPipeline_source.h presence... no
>> checking for source/COIPipeline_source.h... no
>> configure: error: MIC COI LLAPI headers not found
>>
>> $ ls /usr/include/intel-coi/source/COIPipeline_source.h
>> /usr/include/intel-coi/source/COIPipeline_source.h
>>
>> $ ./configure --enable-mic --with-mic-path=/usr/include/intel-coi
>> ...
>> checking whether to compile with MIC support... yes
>> checking source/COIPipeline_source.h usability... no
>>  checking source/COIPipeline_source.h presence... no
>> checking for source/COIPipeline_source.h... no
>> configure: error: MIC COI LLAPI headers not found
>>
>> Best regards,
>> Taras
>>
>>
>>
>> On Fri, Feb 28, 2014 at 10:01 PM, David Beer <dbeer at adaptivecomputing.com
>> > wrote:
>>
>>> Taras,
>>>
>>> Can you share the exact error that you're getting with this? We like to
>>> fix these kind of things :-)
>>>
>>>
>>> On Fri, Feb 28, 2014 at 9:03 AM, Taras Shapovalov <
>>> taras.shapovalov at brightcomputing.com> wrote:
>>>
>>>> Hi guys,
>>>>
>>>> Has anybody built torque 4.2.6.1 with Xeon Phi support (the latest MPSS
>>>> version now is MPSS3)? Looks like ./configure uses built-in paths to coi
>>>> directory that do not exist in the latest MPSS.
>>>>
>>>> I wonder if somebody of you has just hacked the script and are using
>>>> torque with MPSS3 successfully.
>>>>
>>>> Thanks,
>>>> Taras
>>>>
>>>> _______________________________________________
>>>> torqueusers mailing list
>>>> torqueusers at supercluster.org
>>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>>
>>>>
>>>
>>>
>>> --
>>> David Beer | Senior Software Engineer
>>> Adaptive Computing
>>>
>>> _______________________________________________
>>> torqueusers mailing list
>>> torqueusers at supercluster.org
>>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>>
>>>
>>
>> _______________________________________________
>> torqueusers mailing list
>> torqueusers at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>
>>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20140305/77b9bdb2/attachment-0001.html 


More information about the torqueusers mailing list