[torqueusers] Recommended versions for Torque and Moab?

Martin Siegert siegert at sfu.ca
Wed Feb 26 14:30:01 MST 2014


If you are using cpusets, torque-4.2.6* has serious problems and cannot
be recommended. David fixed these problems in December and we downloaded
the git 4.2.7 branch after the fix (TRQ-2369) was implemented. We have
been running that version ever since.
And, yes, it is the most stable version of Torque I can remember.
It is so good that I am afraid to update Torque when the final 4.2.7
version comes out ...

Cheers,
Martin

-- 
Martin Siegert
WestGrid/ComputeCanada Site Lead
Simon Fraser University

On Wed, Feb 26, 2014 at 11:10:36AM -0500, W. Graham McCullough wrote:
> 
>    The most stable version of Torque we've run in the 4.2.* tree at Purdue
>    University is 4.2.6.1. Before that, the 4.1.5.1 was pretty stable, but
>    has some scary security issues ([1]CVE-2013-4495: users could submit a
>    job that would grant them root access) that were resolved in 4.2.6.
>    Patches for CVE-2013-4495 exist if someone recommends something else.
>    4.2.6 itself crashed on us a few times on different clusters, but
>    4.2.6.1 has been running almost without incident for the last few weeks
>    on our gear. I don't have any experience with the old 2.5.* torque, so
>    your milage may vary.
>    Good luck!
>    Graham McCullough
>    HPC systems Administrator
>    Purdue University
> 
>    On Wed, Feb 26, 2014 at 10:36 AM, Sreedhar Manchu <[2]sreedhar at nyu.edu>
>    wrote:
> 
>    Hi All,
>    I am in the process of building a new cluster and now I'm approaching
>    the stage for installing Torque and Moab.
>    On all our clusters, until now we have been using Torque 2.5.X and Moab
>    6.X. On the new cluster I'm thinking of installing newer versions
>    (Torque 4.X and Moab 7.X).
>    In the mailing list I regularly see that many people are using these
>    versions and I could use some recommendation on getting a stable
>    version. Any advise would be much appreciated.
>    Thanks in advance,
>    Sreedhar.
>    HPC Systems Administrator
>    New York University.
> 
>      _______________________________________________
>      torqueusers mailing list
>      [3]torqueusers at supercluster.org
>      [4]http://www.supercluster.org/mailman/listinfo/torqueusers
> 
> References
> 
>    1. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4495
>    2. mailto:sreedhar at nyu.edu
>    3. mailto:torqueusers at supercluster.org
>    4. http://www.supercluster.org/mailman/listinfo/torqueusers

> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers



More information about the torqueusers mailing list