[torqueusers] Warning message for /bin/tcsh users

Gus Correa gus at ldeo.columbia.edu
Thu Feb 6 16:07:45 MST 2014


On 02/06/2014 04:01 PM, Dave Ulrick wrote:
> On Wed, 5 Feb 2014, Gustavo Correa wrote:
>
>> If I remember right, this has been a (harmless) csh/tcsh annoyance
>> since the days of the old PBS, before it was renamed Torque.
>> You can find several postings about it, on this mailing list archives and on
>> Google, along with the workaround that you figured out.
>> It seems to be just a (correct) warning: the job script doesn't have access to TTY,
>> cannot be suspended, put on the background, etc.
>
> In addition to the earlier torqueusers postings, I've found several
> local HPC sites that mention this warning message in their FAQ and
> instruct their users to either ignore the message or use '-S /bin/sh' in
> their PBS scripts. I'm gathering this information to help demonstrate that
> this message is a known but harmless issue.
>
> The only issue I've noticed so far with '-S /bin/sh' comes up when the
> user runs 'qsub -I foo.pbs'. When the compute node shell prompt comes up,
> it's a /bin/sh shell rather than the user's usual shell. This can be
> avoided if the user omits '-S /bin/sh' from the PBS script by commenting
> it out or worked around by the user manually launching a new shell by
> entering 'tcsh', 'bash', or whatever. Only a few of my users seem to use
> 'qsub -I' at all and even fewer users use tcsh so I doubt this will come
> up very often.
>
> Thanks,
> Dave

Hi Dave

When the user switches to sh/bash using '-S /bin/sh', does [s]he get
the usual csh/tcsh environment as if he/she were running
without '-S /bin/sh'?
I haven't tried it.
However, this site seems to say "no".
It says that to setup the environment the user must source
a ~/.bashrc (duplicating the ~/.[t]cshrc environment settings
in bashism perhaps?):

https://www.cac.cornell.edu/wiki/index.php?title=LinuxBatchFAQ#No_Job_Control_Warning_for_CSH_and_TCSH

Anyway, here we just don't bother about that warning message.
Getting rid of it seems to come with even less pleasant side effects,
and gives the user a shell [s]he is not familiar to.

Instead of working hard to prove that the message is harmless
(which it is; it goes to stderr as warnings should go, but that doesn't 
mean it is an error), you could challenge your users to show
it is actually harmful.  :)
Did any job fail because of it?
Are they better off without that message but having to adjust from
tcsh to bash?

**

I couldn't find the stty commands in the intialization scripts
that Michael Jennings said might be responsible for that
annoying message.
At least it is not explicitly in the ~/.[t]cshrc around here,
or in the /etc/csh.cshrc /etc/csh.login that comes
with stock CentOS 6.4, 5.4 and 5.2.
Could setting the prompt be the culprit?
Anyway, maybe I didn't dig enough.

Thank you,
Gus Correa


More information about the torqueusers mailing list