[torqueusers] security advisory

Ole Holm Nielsen Ole.H.Nielsen at fysik.dtu.dk
Thu Sep 19 05:03:15 MDT 2013


Ken Nielson knielson at adaptivecomputing.com wrote:
> *Remedy: *All TORQUE users should patch their systems using the following
> instructions:
>
>
> For 2.5.x versions of TORQUE:
>
> ----------------------------
>
> 1. Download the patch file:
>
>      $ wget
> http://www.adaptivecomputing.com/torquepatch/fix_mom_priv_2.5.patch

Question: Will this patch work correctly with Torque 2.3.x?  Has anyone 
tried and tested this?

The code in src/server/process_request.c seems identical at the lines in 
the above patch in the 2.3.7 and 2.5.12 versions, so there may be hope :-)

We're forced to use the old Torque 2.3.7 because we use the Maui 
scheduler (not Moab), see this thread about Torque/Maui problems: 
http://www.supercluster.org/pipermail/torqueusers/2012-November/015236.html

-- 
Ole Holm Nielsen
Department of Physics, Technical University of Denmark


More information about the torqueusers mailing list