[torqueusers] qsub -p does not work

Matt Britt msbritt at umich.edu
Tue Jun 4 05:45:08 MDT 2013


I can't speak to Maui, but for Moab, did you enable ENABLEPOSUSERPRIORITY
and/or set USERPRIORWEIGHT?

ENABLEPOSUSERPRIORITY  (allows for positive priority settings.  We don't,
only allowing negative priority adjustments)

SERVICEWEIGHT           25
USERPRIOWEIGHT          100

http://docs.adaptivecomputing.com/mwm/7-1-4/help.htm#a.fparameters.html

 - Matt


--------------------------------------------
Matthew Britt
CAEN HPC Group - College of Engineering
msbritt at umich.edu



On Tue, Jun 4, 2013 at 1:59 AM, Clotho Tsang <wytsang at clustertech.com>wrote:

> When one use qsub "-p" option to set a job priority, it may fail as "-p"
> is not used. It is because Maui / Moab ignores the flag.
> qsub "-p" option does not work with Maui / Moab, but works with pbs_sched.
>
> I work around it by
> 1) Use pbs_sched instead of Maui / Moab, or
> 2) Use setspri of Maui / Moab
>
>
> --
> Clotho Tsang
> Senior Software Engineer
> Cluster Technology Limited
> Email: clotho at clustertech.com
> Tel: (852) 2655-6129
> Fax: (852) 2994-2101
> Website: www.clustertech.com
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20130604/ee2b6758/attachment.html 


More information about the torqueusers mailing list