[torqueusers] hwloc error torque 4.1.3

Craig West cwest at vpac.org
Wed Jan 23 22:23:24 MST 2013


Michael,

> I'm still unable to reproduce this behavior, but I think I've found
> the cause.
>
> Let me know if that works.  If so, I'll submit it upstream to Adaptive.
>
> It's poorly documented, but if PKG_CHECK_MODULES() is invoked for the
> first time inside a conditional, PKG_PROG_PKG_CONFIG must be invoked
> unconditionally prior to any PKG_CHECK_MODULES() calls.

Testing this is not simple. Your patch doesn't modify the "configure" 
script, which means I need to run autogen.sh. But I already know that if 
I run autogen.sh then I won't have the problem.

It is worth noting that when you run the configure script, if it fails 
to run fully due to hwloc, you get the following message:


===== QUOTE =====
checking for HWLOC... configure: error: cpuset support requires the 
hwloc package

This can be solved by configuring with --with-hwloc-path=<path>. This 
path should be the path to the directory containing the lib/ and 
include/ directories for your version of hwloc.
Another option is adding the directory containing 'hwloc.pc'
to the PKG_CONFIG_PATH environment variable.

If you have done these and still get this  error, try running 
./autogen.sh and then configuring again.
===== QUOTE =====

I am specifying the --with-hwloc-path, and if I use the same configure 
script after running autogen.sh, then it configures successfully.

Is it possible that the configure script provided with torque 4.1.4 is 
not up to date, and that is what is causing the issue?


Thanks,
Craig.


More information about the torqueusers mailing list