[torqueusers] Bad UID for job execution MSG=ruserok failed validating ...

Carlos Borroto carlos.borroto at gmail.com
Tue Jan 15 15:22:50 MST 2013


On Wed, Nov 7, 2012 at 5:21 PM, Carlos Borroto <carlos.borroto at gmail.com> wrote:
> rsh is not installed in any of the systems, I will like to keep it
> like that. The system users are from LDAP, in case this is relevant.
> The exact same configuration but using torque 2.5 packages from EPEL
> which require munge, does work. I'm ok using munge, but haven't
> figured out why with the packages I'm compiling do not work. Can't
> even tell if munge is being query at all by torque.

Ok, it took me some time, but I figured why my rpm packages didn't
support munge. I didn't realize '--with munge' needed to be set in the
Makefile. I thought by doing './configure --enable-munge-auth; make
rpm' I was enabling munge authentication. This is not the case.

In summary changing this line in the Makefile:
RPM_AC_OPTS =  --with syslog --with scp --without pam --with drmaa

to:
RPM_AC_OPTS =  --with syslog --with scp --without pam --with drmaa --with munge

Will do the trick. I still don't know why the other two options to not
use 'ruserok' are not working. Either way, using munge works for me,
so I'm a happy camper.

Regards,
Carlos


More information about the torqueusers mailing list