[torqueusers] Build of 4.6.2:: libtorque.so.2 reference:: trqauthd now starts

Byron.LengsfieldIii at hgst.com Byron.LengsfieldIii at hgst.com
Mon Dec 16 15:59:25 MST 2013


Roland,


Here is the ldd output (below).   It looks like  /usr/lib/libtorque.so.2 
was old (see below)

I found the proper version in 

/root/4.2.6/src/lib/Libpbs/.libs/libtorque.so.2.0.0

The trqauthd daemon now starts. 

Is this an issue with the download procedure which needs to be corrected. 
It looks like the version of
Ubuntu that was installed contained an oldr version of libtorque.so.2.0.0 
that was not overwritten.

thanks,

Byron


gpu123 at gpu-ThinkStation-D30:~$ ls -l  /usr/lib/libtorque.so.2
lrwxrwxrwx 1 root root 18 Dec  4  2011 /usr/lib/libtorque.so.2 -> 
libtorque.so.2.0.0

gpu123 at gpu-ThinkStation-D30:/usr/lib$ ls -l libtorque.so.2.0.0
-rw-r--r-- 1 root root 185224 Dec  4  2011 libtorque.so.2.0.0

gpu123 at gpu-ThinkStation-D30:~$ ls -l  /usr/local/sbin/trqauthd
-rwxr-xr-x 1 root root 46139 Dec 17 02:48 /usr/local/sbin/trqauthd


root at gpu-ThinkStation-D30:~# ldd /usr/local/sbin/trqauthd
        linux-vdso.so.1 =>  (0x00007fffddf93000)
        libtorque.so.2 => /usr/lib/libtorque.so.2 (0x00007f1861e43000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 
(0x00007f1861c26000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 
(0x00007f1861925000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f1861566000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f1862167000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f186126a000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 
(0x00007f1861053000)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20131216/04f1f2f4/attachment.html 


More information about the torqueusers mailing list