[torqueusers] Build of 4.6.2

rf at q-leap.de rf at q-leap.de
Mon Dec 16 12:48:05 MST 2013


>>>>> "Byron" == Byron LengsfieldIii <Byron.LengsfieldIii at hgst.com> writes:

Hi Byron,

    Byron> Ken,
    Byron>  I just tried with autogen.sh and obtained the same error

    Byron> root at gpu-ThinkStation-D30:~/4.2.6# /usr/local/sbin/trqauthd
    Byron> start /usr/local/sbin/trqauthd: symbol lookup error:
    Byron> /usr/local/sbin/trqauthd: undefined symbol: debug_mode

have you tried the following?

$ ldd /usr/local/sbin/trqauthd

Most likely you're pulling the wrong libtorque.so.2 (maybe from package
libtorque2). Make sure you're getting the libtorque that was compiled
with your trqauthd.

Roland
--
https://qlustar.com

    Byron> (orginally I tried with the shell script in the
    Byron> README.configure note
    Byron> #! /bin/sh
    Byron> libtoolize --force --copy \ && aclocal \ && autoheader \ &&
    Byron> automake --foreign --add-missing --force-missing --copy \ &&
    Byron> autoconf )

    Byron>  I am trying to install a GPU application at a Research
    Byron>  Center in Japan.
    Byron> They installed Ubuntu 12.04.3 LTS Ubuntu 12.04.3 LTS
    Byron> (GNU/Linux 3.8.0-29-generic x86_64)

    Byron> we have

    Byron> Ubuntu 12.04.3 LTS (GNU/Linux 3.8.0-33-generic x86_64)
    Byron> running at the US lab.  The operating and batch system was
    Byron> installed by a vendor, Advanced HPC, and with a bit of work
    Byron> Torque operates properly with the GPUs.

    Byron>  I don't know the details of the installation in Japan, the
    Byron>  system was
    Byron> original operating under Windows and they may be operating in
    Byron> a dual boot environment.

    Byron> Thanks for your help.

    Byron> Byron

    Byron> Ken Nielson <knielson at adaptivecomputing.com> Sent by:
    Byron> torqueusers-bounces at supercluster.org 12/12/2013 08:08 PM
    Byron> Please respond to Torque Users Mailing List
    Byron> <torqueusers at supercluster.org>


    Byron> To Torque Users Mailing List <torqueusers at supercluster.org>
    Byron> cc

    Byron> Subject Re: [torqueusers] Build of 4.6.2

    Byron> Byron,

    Byron> Did you run autogen.sh and then configure.

    Byron> If so what configure options did you use?

    Byron> Thanks

    Byron> On Wed, Dec 11, 2013 at 5:18 PM,
    Byron> <Byron.LengsfieldIii at hgst.com> wrote:

    Byron> David,

    Byron> I attempted to install Torque 4.2.6 from both github and the
    Byron> zip file.The build seem to go smoothly but when I issue the
    Byron> command

    Byron> sudo trqauthd start

    Byron> the following error event is logged.

    Byron> trqauthd: symbol lookup error: trqauthd: undefined symbol:
    Byron> debug_mode

    Byron> Any idea what package is missing.

    Byron> Thanks, Byron Lengsfield, PhD Recording Integration Lab HGST


More information about the torqueusers mailing list