[torqueusers] Torque 4.1.2 does not accept hostname with '-'

Clotho Tsang wytsang at clustertech.com
Wed Oct 17 19:03:03 MDT 2012


The following problem is found at Torque 4.1.2, but not 4.1.0.

At RHEL6, if the headnode hostname consists of char "-",
jobs will keep running but not stop, checkjob shows message
"cannot start job - RM failure, rc: 15033, msg: 'End of File' "

The problem is not found if the hostname has no "-".

=======================================

 [root at hp-mgmt-1 maui]# checkjob 3309


checking job 3309

State: Running
Creds:  user:huadi  group:group1  class:batch  qos:DEFAULT
WallTime: 00:03:07 of 1:00:00
SubmitTime: Thu Oct 11 11:14:00
  (Time Queued  Total: 00:00:02  Eligible: 00:00:02)

StartTime: Thu Oct 11 11:14:02
StartDate: -00:03:08  Thu Oct 11 11:14:03
Total Tasks: 5

Req[0]  TaskCount: 5  Partition: DEFAULT
Network: [NONE]  Memory >= 0  Disk >= 0  Swap >= 0
Opsys: [NONE]  Arch: [NONE]  Features: [NONE]
Allocated Nodes:
[hp-compute-19:5]


IWD: [NONE]  Executable:  [NONE]
Bypass: 0  StartCount: 1
PartitionMask: [ALL]
Flags:       RESTARTABLE

Reservation '3309' (-00:03:09 -> 00:56:51  Duration: 1:00:00)
Messages:  cannot start job - RM failure, rc: 15033, msg: 'End of File'
PE:  5.00  StartPriority:  1




-- 
Clotho Tsang
Senior Software Engineer
Cluster Technology Limited
Email: clotho at clustertech.com
Tel: (852) 2655-6129
Fax: (852) 2994-2101
Website: www.clustertech.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20121018/b7e2ad4c/attachment.html 


More information about the torqueusers mailing list