[torqueusers] upgrading from 3.0.2 to 4.1.2 with NUMA support

Tom Rosmond rosmond at reachone.com
Mon Oct 15 15:36:26 MDT 2012


I see one error myself:

I have 'mom_layout' instead of 'mom.layout'.  However now I just get

---------------------------------------------------------------

10/15/2012 14:30:19;0002;   pbs_mom.27442;Svr;pbs_mom;Torque Mom Version
= 4.1.2, loglevel = 0
10/15/2012 14:30:30;0002;
pbs_mom.27442;Svr;setup_program_environment;machine topology contains 2
memory nodes, 32 cpus
10/15/2012 14:30:30;0001;
pbs_mom.27442;Svr;pbs_mom;LOG_ERROR::read_layout_file, nodeboard 0 has
no nodeset
10/15/2012 14:30:30;0001;
pbs_mom.27442;Svr;pbs_mom;LOG_ERROR::setup_nodeboards, Could not read
layout file!

---------------------------------------------------------------

So something I am still missing something somewhere.  What is
'read_layout_file'?

T. Rosmond


On Mon, 2012-10-15 at 11:58 -0700, Tom Rosmond wrote:
> I have been successfully running Torque version 3.0.2 for several months
> on a 2 NUMA node workstation.  Recently I decided to try upgrading to
> 4.1.2.  I essentially duplicated my 3.0.2 setup, i.e. the same
> 'configure' options, the same 'server_priv/nodes' and
> 'mom_priv/mom_layout' files.  Here are those details:
> 
> ./configure --prefix=/opt/torque --enable-numa-support
> --enable-libcpuset
> 
> 'nodes' file
>     fir.reachone.com np=32 num_numa_nodes=2
> 
> 'mom_layout' file
>      cpus=0-15   mem=0
>      cpus=16-31  mem=1
> 
> 
> As I said, these are identical to what I used to successfully configure
> with 3.0.2.
> 
> Yet when I try to start 'pbs_mom', I get this:
> 
> --------------------------------------------------------------
> 
> root at fir:~# /opt/torque/sbin/pbs_mom
> pbs_mom: LOG_ERROR::No such file or directory (2) in read_layout_file,
> Unable to read the layout file in /var/spool/torque/mom_priv/mom.layout
> 
> pbs_mom: LOG_ERROR::setup_nodeboards, Could not read layout file!
> 
> -----------------------------------------------------------------
> 
> The other daemons (pbs_server, trqauthd) start successfully, so there
> must be something different vis-a-vis pbs_mom for NUMA configuration
> between 3.0.2 and 4.1.2. I have looked carefully at 'config.log' and
> everything seems normal.  And the 'mom.layout' file is clearly present.
> Any suggestions?
> 
> T. Rosmond
> 
> 
> 
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers



More information about the torqueusers mailing list