[torqueusers] maui and torque not communicating

DuChene, StevenX A stevenx.a.duchene at intel.com
Mon Mar 19 11:35:17 MDT 2012


BTW, the next log entry right after this is:

03/19/2012 10:11:06;0002;PBS_Server;node;close_conn;Connection 10 - func 4403a0

Now I don't know if this is related to my non-communication issue or not.
--
Steven DuChene

From: torqueusers-bounces at supercluster.org [mailto:torqueusers-bounces at supercluster.org] On Behalf Of DuChene, StevenX A
Sent: Monday, March 19, 2012 10:25 AM
To: Torque Users Mailing List
Subject: Re: [torqueusers] maui and torque not communicating

Would there be any symptoms in either the torque or maui log files that I can look for that would match any of the issues that this patch would address?

I don't recall seeing anything about host verification errors in either place.

I am seeing this sort of error in the torque server log files:

03/19/2012 10:11:06;0001;PBS_Server;Svr;PBS_Server;LOG_ERROR::process_pbs_server_port, Socket (10) close detected from 36.101.8.27:15004

Is that a pointer that would reference this problem?
--
Steven DuChene

From: torqueusers-bounces at supercluster.org [mailto:torqueusers-bounces at supercluster.org] On Behalf Of Ken Nielson
Sent: Monday, March 19, 2012 10:01 AM
To: Torque Users Mailing List
Subject: Re: [torqueusers] maui and torque not communicating

On Mon, Mar 19, 2012 at 10:53 AM, DuChene, StevenX A <stevenx.a.duchene at intel.com<mailto:stevenx.a.duchene at intel.com>> wrote:
Ken:
Thanks for the offer of a patch. Do the symptoms you see with this match what I reported?
Like I indicated it seems the communication between maui & torque is not completely functional.
According to my maui log files some communication is happening but not anything even close to enough for the whole system to work as intended.
--
Steven DuChene

Steven,

I cannot say that they match. But when Maui communicates with TORQUE there is some name and host verification done.

Ken

From: torqueusers-bounces at supercluster.org<mailto:torqueusers-bounces at supercluster.org> [mailto:torqueusers-bounces at supercluster.org<mailto:torqueusers-bounces at supercluster.org>] On Behalf Of Ken Nielson
Sent: Monday, March 19, 2012 9:30 AM

To: Torque Users Mailing List
Subject: Re: [torqueusers] maui and torque not communicating


On Mon, Mar 19, 2012 at 9:51 AM, DuChene, StevenX A <stevenx.a.duchene at intel.com<mailto:stevenx.a.duchene at intel.com>> wrote:
RHEL6.1 with latest standard kernel.

Steve,

We have found a problem with CentOS6 where getaddrinfo returns localhost.localdomain instead of a hostname internally in TORQUE. We currently try to authorize connections using only localhost. I am making a fix for this to 4.0.1. I could send you a patch for the 4.0 code if you want.

Of course I am guessing that is the problem, but you would know with the patch if it is.

Ken

_______________________________________________
torqueusers mailing list
torqueusers at supercluster.org<mailto:torqueusers at supercluster.org>
http://www.supercluster.org/mailman/listinfo/torqueusers

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20120319/5b70a10f/attachment-0001.html 


More information about the torqueusers mailing list