[torqueusers] TORQUE 4.0 Officially Announced

DuChene, StevenX A stevenx.a.duchene at intel.com
Mon Mar 19 08:47:28 MDT 2012


Also a better (more complete) explanation of what features are enabled when hwloc is used would be helpful as well.

BTW, I built torque on my server without hwloc installed and then installed the resulting mom packages on my nodes. The mom daemons in that case did seem to start up just fine.
--
Steven DuChene

-----Original Message-----
From: torqueusers-bounces at supercluster.org [mailto:torqueusers-bounces at supercluster.org] On Behalf Of Craig West
Sent: Sunday, March 18, 2012 10:40 PM
To: Torque Users mailing list; Torque Developers mailing list
Subject: Re: [torqueusers] TORQUE 4.0 Officially Announced


Hi Steven,

I have just begun testing Torque 4.0, as hwloc has been a long awaited 
feature for me.

> It is unclear from this announcement text where hwloc has to be installed.
> Is it just on the server or on the nodes only?

It needs to be available on the BUILD server and the nodes. I tried to 
run pbs_mom on a node without the hwloc I had installed and it failed.

Note: I am running hwloc 1.4 from a directory in /usr/local
This was not automatically found by the TORQUE configure script, but you 
can specify the location using HWLOC_CFLAGS & HWLOC_LIBS.
It embeds the locations that you specify in the pbs_mom (and other 
files) but it seems you can set the LD_LIBRARY_PATH variable if it is 
not in the same location on the BUILD server as the compute nodes.
For simplicity installing them in the same location makes sense.

> More documentation about this would be greatly appreciated.

I agree, clearer and more detailed documentation would be useful.

Cheers,
Craig.
_______________________________________________
torqueusers mailing list
torqueusers at supercluster.org
http://www.supercluster.org/mailman/listinfo/torqueusers


More information about the torqueusers mailing list