[torqueusers] Torque-4.0 bug? conflicting types for get_svrport

Joseph Farran jfarran at uci.edu
Fri Mar 16 13:51:23 MDT 2012


After compiling Torque 4.0.0, I started fresh with:

    /opt/torque/sbin/pbs_server -t create

I then re-read my qmgr comfigs from my old Torque.   I was also able to 
stop and start Torque v4 just fine.

I then added a node, or made changes to it ( I forget ) and Torque 
died.   When I tried to start it again, it said:

    # service pbs_server start
    Starting TORQUE Server: PBS_Server: LOG_ERROR::svr_recov_xml, No 
server tag found in the database file???
    PBS_Server: LOG_ERROR::recov_svr_attr, Unable to read server database
    /opt/torque/sbin/pbs_server: failed to get server attributes

Fun day.

DuChene, StevenX A wrote:
> Can you explain the steps you used to reproduce the corrupt DB problem?
> --
> Steven DuChene
>
> -----Original Message-----
> From: torqueusers-bounces at supercluster.org [mailto:torqueusers-bounces at supercluster.org] On Behalf Of Joseph Farran
> Sent: Friday, March 16, 2012 12:10 PM
> To: Torque Users Mailing List
> Subject: Re: [torqueusers] Torque-4.0 bug? conflicting types for get_svrport
>
> I too just finished testing / wasting several hours trying to go from 
> Torque 2.4.9 to version 4 and version 4 is NOT ready for prime time.
>
> There is also a nasty bug where it will corrupt the Torque db.      Did 
> not have time to write the erros, but I was able to repeat it.
>
> Don't try to upgrade on a production system!
>
> Joseph
>
> DuChene, StevenX A wrote:
>   
>> I am attempting to compile Maui-3.3.1 on a system where I recently installed Torque-4.0 rpms I built from the spec file included with the Torque 4.0 sources. I am getting the following error out when the system attempts to build MPBSI.c
>>
>> gcc -I../../include/ -I/usr/local/maui/include     -I/usr/include/torque -D__LINUX   -D__MPBS        -g -O2 -D__M64  -c MPBSI.c
>> MPBSI.c:177: error: conflicting types for âget_svrportâ
>> /usr/include/torque/pbs_ifl.h:681: note: previous declaration of âget_svrportâ was here
>> MPBSI.c:178: error: conflicting types for âopenrmâ
>> /usr/include/torque/pbs_ifl.h:682: note: previous declaration of âopenrmâ was here
>> make[1]: *** [MPBSI.o] Error 1
>> make[1]: Leaving directory `/usr/local/src/maui-3.3.1/src/moab'
>> make: *** [all] Error 2
>>
>> --
>> Steven DuChene
>>
>> _______________________________________________
>> torqueusers mailing list
>> torqueusers at supercluster.org
>> http://www.supercluster.org/mailman/listinfo/torqueusers
>>
>>
>>   
>>     
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
>   


More information about the torqueusers mailing list