[torqueusers] Torque-4.0 bug? conflicting types for get_svrport

Joseph Farran jfarran at uci.edu
Fri Mar 16 13:10:26 MDT 2012


I too just finished testing / wasting several hours trying to go from 
Torque 2.4.9 to version 4 and version 4 is NOT ready for prime time.

There is also a nasty bug where it will corrupt the Torque db.      Did 
not have time to write the erros, but I was able to repeat it.

Don't try to upgrade on a production system!

Joseph

DuChene, StevenX A wrote:
> I am attempting to compile Maui-3.3.1 on a system where I recently installed Torque-4.0 rpms I built from the spec file included with the Torque 4.0 sources. I am getting the following error out when the system attempts to build MPBSI.c
>
> gcc -I../../include/ -I/usr/local/maui/include     -I/usr/include/torque -D__LINUX   -D__MPBS        -g -O2 -D__M64  -c MPBSI.c
> MPBSI.c:177: error: conflicting types for âget_svrportâ
> /usr/include/torque/pbs_ifl.h:681: note: previous declaration of âget_svrportâ was here
> MPBSI.c:178: error: conflicting types for âopenrmâ
> /usr/include/torque/pbs_ifl.h:682: note: previous declaration of âopenrmâ was here
> make[1]: *** [MPBSI.o] Error 1
> make[1]: Leaving directory `/usr/local/src/maui-3.3.1/src/moab'
> make: *** [all] Error 2
>
> --
> Steven DuChene
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
>   


More information about the torqueusers mailing list