[torqueusers] Does Torque-2.5.11 require glibc v 2.14?

Axel Kohlmeyer akohlmey at cmm.chem.upenn.edu
Mon Jun 4 09:28:02 MDT 2012


On Mon, Jun 4, 2012 at 2:32 AM, John Keller <jwkeller at alaska.edu> wrote:
> I am trying  to run pbs_mom on a node with openSUSE 11.4, which has
> glibc v 2.11. I get an error message:
>
> pbs_mom: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by pbs_mom)
> pbs_mom: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by
> /usr/local/lib64/libtorque.so.2)
>
> I read on the web that glibc v 2.14 is not compatible with openSUSE
> 11.4. sheesh! Maybe I should go back to an earlier version of Torque.
> If so, which one do you recommend?

this has nothing to do with the version of torque,
but rather the version of glibc that was present
on the machine that this particular set of binaries
was compiled. if you want to use the same set of
torque binaries across a wide range of machines,
you have to compile them on the machine with
the "oldest" glibc installation. glibc is backward,
but not forward compatible.

axel.

>  John Keller
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers



-- 
Dr. Axel Kohlmeyer    akohlmey at gmail.com
http://sites.google.com/site/akohlmey/

Institute for Computational Molecular Science
Temple University, Philadelphia PA, USA.


More information about the torqueusers mailing list