[torqueusers] Torque4 NUMA

David Beer dbeer at adaptivecomputing.com
Mon Jan 30 09:32:18 MST 2012


Joerg,

See below.

On Mon, Jan 30, 2012 at 6:18 AM, Joerg Blank <j.blank at fz-juelich.de> wrote:

> Hello,
>
> Thanks for your answers.
>
> > You are correct in that you should use the nodes=X syntax. I wonder how
> > meaningful your NUMA test can be for a node that has only one cpu and
> > one NUMA node, but that is a separate concern. I'm sorry the docs
> > haven't been updated yet, I will get that updated ASAP.
>
> I brew a new Debian package for Torque4 and was testing the
> installation. I figured I could configure it and see if everything
> connects, etc. No performance test were done on this virtual machine ;-)
>
>
Understood.


> > I'm surprised you're having trouble getting the mom to connect to the
> > server. What are the errors you're getting here?
>
> I figured out that the num_numa_nodes parameter was also renamed.
> Is there a way to have non-NUMA nodes in the same cluster?
>
>
Sorry about that. I forgot to point that out to you either - it should be
num_node_boards. I will also get this updated in the documentation.


> > This can't have anything to do with the mom.layout file. TORQUE does not
> > edit the permissions of these directories, it just attempts to access
> > them. What was the error?
>
> I removed --enable-cpuset and --enable-libcpuset from the configure
> call. Do I still get process binding?
>
>
Yes, you will still get process binding without these lines.


> Regards,
>
> Jörg Blank
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>



-- 
David Beer | Software Engineer
Adaptive Computing
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20120130/df07879a/attachment.html 


More information about the torqueusers mailing list