[torqueusers] Torque4 NUMA

David Beer dbeer at adaptivecomputing.com
Fri Jan 27 09:44:25 MST 2012


Please see my answers inline.

On Thu, Jan 26, 2012 at 8:56 AM, Joerg Blank <j.blank at fz-juelich.de> wrote:

> Hello,
>
> I tried installing Torque4 with NUMA support in a Virtualbox and got
> stopped by the mom.layout file. The documentation still talks about
> "cpus" and "mem", but the source code looks like the syntax changed.
>

I tried "nodes=1" (my vbox machine has only one cpu), got the mom to
> start, but could not get it to connect to pbs_server.
> How should that file look in Torque4?
>
>
You are correct in that you should use the nodes=X syntax. I wonder how
meaningful your NUMA test can be for a node that has only one cpu and one
NUMA node, but that is a separate concern. I'm sorry the docs haven't been
updated yet, I will get that updated ASAP.

I'm surprised you're having trouble getting the mom to connect to the
server. What are the errors you're getting here?


> I also had to deactivate libcpuset support because it could not write
> into /dev/cpuset/torque, but that may be due to a misconfigured layout.
>
>
This can't have anything to do with the mom.layout file. TORQUE does not
edit the permissions of these directories, it just attempts to access them.
What was the error?


>
> Regards,
> Joerg Blank
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>



-- 
David Beer | Software Engineer
Adaptive Computing
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20120127/1d491f41/attachment.html 


More information about the torqueusers mailing list