[torqueusers] PBS_NODEFILE: Undefined variable.

Sreedhar Manchu sm4082 at nyu.edu
Thu Feb 23 07:35:47 MST 2012


Hi Ken,

This morning I did few more test runs and found out it's #PBS -V in script that's causing problems. Whenever I include it I'm seeing this error.

I think it's trying to look for this variable in user's exported environment rather than looking into variables defined by it self. Everything works fine if I take -V off the script. 

But the problem is some users need to mention this in their scripts to export not only user defined variables but also system variables such as LD_LIBRARY_PATH. 

Is there a way to fix it? Now I'll do some more tests to see we have same problem with other pbs variables such as PBS_O_WORKDIR etc. 

Please let me know if you have any suggestions. I will send another email once I do more testing. 

Thanks
Sreedhar. 

--
Sent from my phone. Please excuse my brevity and any typos.

On Feb 22, 2012, at 14:58, Ken Nielson <knielson at adaptivecomputing.com> wrote:

> ----- Original Message -----
>> From: "Sreedhar Manchu" <sm4082 at nyu.edu>
>> To: "Torque Users Mailing List" <torqueusers at supercluster.org>
>> Sent: Wednesday, February 22, 2012 11:22:16 AM
>> Subject: [torqueusers] PBS_NODEFILE: Undefined variable.
>> 
>> Hi,
>> 
>> Recently, I have upgraded Torque to it's 2.5.10 version. Since then
>> we have been seeing this error "PBS_NODEFILE: Undefined variable.".
>> If we restart pbs mom then everything works fine. Does anyone have
>> any idea what's causing this behavior?
>> 
>> Please let me know if you need any information that could help in
>> figuring out the problem.
>> 
>> Thanks,
>> Sreedhar.
> 
> Sreedhar,
> 
> Is the error showing up at the console or in the log file?
> 
> Ken
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers


More information about the torqueusers mailing list