[torqueusers] queue to node mapping is wrong when use '-l procs' option

Xiangqian Wang jascha.wang at gmail.com
Thu Feb 9 03:17:53 MST 2012


Thank you, Gareth

It seems that adding standing reservation in maui config has the same
effect to my torque config before. What I did is:

add following configuration to maui.cfg:

SRCFG[queue01] CLASSLIST=queue01
SRCFG[queue01] NODEFEATURES=queue01
SRCFG[queue01] PERIOD=INFINITY
SRCFG[queue01] RESOURCES=PROCS:1

and create a queue named 'queue01', set feature 'queue01' to a node
'cnode01'

When I submit job through queue01, the cnode01 is not allocated.

Seems that it's a bug of maui.

Xiangqian


2012/2/8 <Gareth.Williams at csiro.au>

> Sounds like there is a bug.
>
> You might be able to work around it by using the queue to node mapping
> described here:
> http://www.supercluster.org/pipermail/mauiusers/2012-February/004839.html
>
> Gareth
>
> > I failed to test queue to node mapping feature of torque/maui system, I
> use torque 2.5.8 and maui 3.2.6p21. the simple job script contains a procs
> option:
> >
> > #!/bin/sh
> > #PBS -N simple-job
> > #PBS -l procs=3
> > #PBS -q fluent
> > #PBS -d /opt/share/job
> > cd $PBS_O_WORKDIR
> > date
> > sleep 30
> > date
>
> -snip-
> ______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20120209/8110218d/attachment-0001.html 


More information about the torqueusers mailing list