[torqueusers] error opening pipe in PBSD_munge_authenticate: errno = 24

Fabien Archambault fabien.archambault at univ-amu.fr
Wed Feb 1 01:15:41 MST 2012


Dear list,

I updated torque to version 2.5.9 and also updated CentOS. Since this
update I have some issues with munge. I do not know why it is useful but is
a dependency of python-pbs which is required by jomonarch.
I tried to find online some information on this message but did not get any
result.

This is the munge version: munge-0.5.8-8.el5
I created the key using create-munge-key on the master then copied to all
nodes (all nodes have the same version).

In /var/log/messages I do not have any reference to munge.
# service munge status
munged (pid 9524) is running... (also on nodes)
# tail /var/log/munge/munged.log
2012-01-31 11:24:47 Notice:    Exiting on signal=15
2012-01-31 11:24:47 Info:      Wrote 1024 bytes to PRNG seed
"/var/lib/munge/munge.seed"
2012-01-31 11:24:47 Notice:    Stopping munge-0.5.8 daemon (pid 1704)
2012-01-31 11:24:47 Notice:    Running on "slater.up.univ-mrs.fr"
(147.94.185.151)
2012-01-31 11:24:47 Info:      PRNG seeded with 1024 bytes from
"/var/lib/munge/munge.seed"
2012-01-31 11:24:47 Info:      Updating supplementary group mapping every
3600 seconds
2012-01-31 11:24:47 Info:      Enabled supplementary group mtime check of
"/etc/group"
2012-01-31 11:24:47 Notice:    Starting munge-0.5.8 daemon (pid 9524)
2012-01-31 11:24:47 Info:      Created 2 work threads
2012-01-31 11:24:47 Info:      Found 35 users with supplementary groups in
0.001 seconds


Torque is configured with
./configure --disable-mom --disable-cpuset --disable-gui --with-rcp=scp

If someone has some clue. Thanks,
Fabien
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20120201/c49d4932/attachment.html 


More information about the torqueusers mailing list