[torqueusers] hwloc error torque 4.1.3

Michael Jennings mej at lbl.gov
Thu Dec 13 15:13:58 MST 2012


On Thursday, 13 December 2012, at 21:29:41 (+0000),
Andrus, Brian Contractor wrote:

> It seems fine:
> 
> [root at build SPECS]# pkg-config --atleast-version 1.1 hwloc && echo "Yep." || echo "Nope."
> Yep.

Then pkgconfig appears to know you have it, which means the only thing
left I can think of is the macro.  Try this:

$ make maintainer-clean
$ rm -f aclocal.m4
$ ./configure --enable-cpuset

See what that does.



On Thursday, 13 December 2012, at 14:50:33 (-0700),
David Beer wrote:

> Have you made sure you are specifying --with-hwloc-path correctly? /usr/
> seems unlikely to be correct. Note the coment that configure adds:
> 
> Specifies the path to the hwloc libraries and include files.
>                        Example: ./configure
> --with-hwloc-path=/usr/local/hwloc-1.1
>                        Will specify that the include files are in
> /usr/local/hwloc-1.1/include and
>                        the libraries are in /usr/local/hwloc-1.1/lib],
> 
> So specifying /usr would mean that
> 
> /usr/include contains the hwloc headers and /usr/lib/ contains the library.

This is correct for RHEL-based systems with hwloc installed from RPM.
It works fine on my SL6 box with --with-hwloc-path=/usr (though it
also works without that).

Michael

-- 
Michael Jennings <mej at lbl.gov>
Senior HPC Systems Engineer
High-Performance Computing Services
Lawrence Berkeley National Laboratory
Bldg 50B-3209E        W: 510-495-2687
MS 050B-3209          F: 510-486-8615


More information about the torqueusers mailing list