[torqueusers] hwloc error torque 4.1.3

Andrus, Brian Contractor bdandrus at nps.edu
Mon Dec 10 12:20:02 MST 2012


This seems to have crept back into torque 4.1.3:

./configure --enable-cpuset produces:
----------snip---------------------
checking for HWLOC... configure: error: cpuset support requires the hwloc package



This can be solved by configuring with --with-hwloc-path=<path>. This path
should be the path to the directory containing the lib/ and include/ directories
for your version of hwloc.
Another option is adding the directory containing 'hwloc.pc'
to the PKG_CONFIG_PATH environment variable.

If you have done these and still get this  error, try running ./autogen.sh and
then configuring again.

[root at build torque-4.1.3]# ls -l $PKG_CONFIG_PATH/hwloc.pc
-rw-r--r-- 1 root root 257 Jul 19  2011 /usr/lib64/pkgconfig//hwloc.pc

-----------------------

Tried using all the usual stuff, to no avail.
Stock hwloc and hwloc-devel installed on CentOS 6.3

Any ideas out there?


Brian Andrus
ITACS/Research Computing
Naval Postgraduate School
Monterey, California
voice: 831-656-6238





More information about the torqueusers mailing list