[torqueusers] Unauthorized Request

Vt Vt vt7500 at yahoo.com
Tue Sep 27 21:26:50 MDT 2011


Thanks for the suggestions.. They worked. I have already submitted a few jobs and they are running.
 
According to your suggestion, here is what I did [I have a single machine]:
 
# contents of my /etc/hosts file
127.0.0.1     localhost
# 127.0.1.1  XXXX.XX.XXX      (yes I commented that line)
nnn.nnn.nnn.nn     XXXX.XX.XXX    
# the above line was added instead where nnn.nnn.nnn.nn was my static ip and XXXX.XX.XXX was my hostname
 
could add a new queue without any "Unauthorized Request" errors
 
Thanks for the help!
 
 


From: Mike Reppert <mreppert at mit.edu>
To: Vt Vt <vt7500 at yahoo.com>; Torque Users Mailing List <torqueusers at supercluster.org>
Sent: Tuesday, September 27, 2011 1:19 PM
Subject: Re: [torqueusers] Unauthorized Request


I ran into exactly the same issue installing on Natty. The solution for me was to modify the /etc/hosts file from the Ubuntu default. I have pasted below some notes that I made on fixing the issues in our install. 

Best,
Mike


The installation instructions at http://www.clusterresources.com/torquedocs21/1.1installation.shtml worked very well, up to a few glitches (which cost several days)
described below: the first with recognizing the proper host address
(fixed by editing the /etc/hosts file) and the second due to problems
with password-less ssh for scp file transfer from the compute nodes
back to the head (fixed using ssh-keygen and setting the proper
permissions).   
The online installation instructions
say simply to go to the torque-2.4.8 directory and type (as sudo):   
$ ./configure  
$ make  
$ make install  

I found that in addition, before
running Torque (probably better before installation), the file
/etc/hosts needs to be modified from the Ubuntu default. In
place of the first few lines (the ipv4 part) reading   
127.0.0.1 localhost  
127.0.1.1 <host domain name>   
< more stuff about IPv6 >    
(the lines here are the Ubuntu 11.04
default) one should add the actual (static, internal) ip addresses of
both the head and compute nodes:   
127.0.0.1 localhost  
<static internal ip for host> 
<host domain name>  
<static internal ip for compute #1> <compute node #1 domain name> 
<static internal ip for compute #2> <compute node #2 domain name>  
< same stuff about IPv6 >  

For example, if your head node domain
name is headnode (local static ip 192.168.1.100) and you have two
compute nodes named compute-0-0 and compute-0-1, the /etc/hosts might
look like   
127.0.0.1 localhost  
192.168.1.100  headnode 
192.168.1.253  compute-0-0 
192.168.1.254  compute-0-1  
< same stuff about IPv6 >  

This is important so that the
pbs_server recognizes the head node as the actual host -- otherwise,
it will be confused and try doing things like communicating with
"root at localhost" instead of "root@<domain name>"
(i.e. “root at headnode” in our example). The problem is that both
127.0.0.1 and 127.0.1.1 are ip addresses which point to the computer
itself. One needs the actual static ip of headnode in the second
line or either (1) the qmgr on the head node will not recognize the
head node itself or (2) the compute nodes will try communicating with
"127.0.0.1" (i.e. themselves) rather than with the head
node.  





On Mon, Sep 26, 2011 at 3:20 PM, Vt Vt <vt7500 at yahoo.com> wrote:


>
>Hi,
>I have been baffled by the error "Unauthorized Request" that I keep getting while installing torque. I tried several versions including 3.0.2 and some older versions.
>
>System:    Ubuntu 11.04 Natty Narhwal
>machine type : its a single cpu (12 core machine)
>
>I am trying to use just 8 cores for the setup. My questions are:
>
>(1) how to get rid of this error?
>server logs:
>PBS_Server;Req;req_reject;Reject reply code=15007(Unauthorized Request ), aux=0, type=Manager, from root at localhost
>
>
># qmgr -c 'p s '
>#
># Set server attributes.
>#
>set server acl_hosts = XXXX
>set server log_events = 511
>set server mail_from = adm
>set server scheduler_iteration = 600
>set server node_check_rate = 150
>set server tcp_timeout = 6
>
>#  create queue batch
>
>qmgr obj=batch svr=default: Unauthorized Request
>
>
>Qmgr: list server managers
>Server XXXX.XX.XXXX.XXX   (no output)
>
>
>
>Qmgr: set server managers+=root at XXXX
>qmgr obj= svr=default: Unauthorized Request 
>
>trying qterm gives the same result.
>
>
>
>(2) how do I add a host to server_manager?
>
>
>
>(3)  How do I completely uninstall torque when I install torque from a tarball using default parameters?
>
>(4) has anybody got a detaled info on a ubuntu 11.04 + torque install ?
>
>_______________________________________________
>torqueusers mailing list
>torqueusers at supercluster.org
>http://www.supercluster.org/mailman/listinfo/torqueusers
> 


More information about the torqueusers mailing list