[torqueusers] enable-gui problem on SLES11-SP1

Gabe Turner gabe at msi.umn.edu
Thu Sep 8 10:25:34 MDT 2011

On Thu, Sep 08, 2011 at 01:17:46PM -0300, Albino A. Aveleda wrote:
> I updated the tk packages.
> # rpm -qa | egrep '^t(cl|k)-'
> tk-8.5.5-3.14.1
> tk-devel-8.5.5-3.14.1
> tcl-devel-8.5.5-2.81
> tcl-8.5.5-2.81
> And now I have the same version that you. I tried 
> to compile again. 
> # ./configure --enable-gui
> [... skip ...]
> checking for Tk_Init... no
> configure: Your Tk install is broken.  Disabling Tk support.
> checking whether to include the GUI-clients... configure: error: cannot build GUI without Tk library
> But I received the same error.
> Do you have some sugestion?

Open up config.log and search for 'Tk_Init'. Hopefully there is an error in
the lines following "checking for TK_Init". This is what it looks like if
it's working properly:

configure:33373: checking for Tk_Init
configure:33430: gcc -o conftest -g -O2 -D_LARGEFILE64_SOURCE       conftest.c   -L/usr/lib64 -ltk8.5 -L/usr/lib64 -lX11 -lXss -lXext 
-L/usr/lib64 -ltcl8.5 -ldl -lieee -lm >&5
configure:33436: $? = 0

It's linking in a number of X libraries, too. perhaps you are missing one or
more of them.
Gabe Turner                                             gabe at msi.umn.edu
HPC Systems Administrator,
University of Minnesota
Supercomputing Institute                          http://www.msi.umn.edu

More information about the torqueusers mailing list