[torqueusers] enable-gui problem on SLES11-SP1

Gus Correa gus at ldeo.columbia.edu
Thu Sep 8 09:00:46 MDT 2011


Gabe Turner wrote:
> On Thu, Sep 08, 2011 at 08:17:55AM -0300, Albino A. Aveleda wrote:
>> Hi Gus,
>>
>> Yes, my machine is 64bit. When I received this error I had only 64-bit 
>> packages. Then I installed the 32-bit too, but I had the same error.
>> All configuration in tkConfig.sh file are 64-bit.
>>
>> I don´t know what happen. I don´t have this problem on RHEL and CentOS 
>> linux.
>>
> 
> I don't seem to have this problem on SLE11 SP1. We don't use the GUI, so I
> never build it, but I just tried a 'configure --enable-gui' and it worked
> fine:
> 
> --------
> [~/torque-2.5.8] % ./configure --enable-gui
> .
> .
> .
> configure: Starting Tcl/Tk configuration
> checking for Tcl configuration... found /usr/lib64/tclConfig.sh
> checking for existence of /usr/lib64/tclConfig.sh... loading
> checking for Tcl public headers... /usr/include
> checking for tclx configuration... none
> checking for Tk configuration... found /usr/lib64/tkConfig.sh
> checking for existence of /usr/lib64/tkConfig.sh... loading
> checking for Tk public headers... /usr/include
> checking for Tcl_Init... yes
> checking for Tk_Init... yes
> checking whether to include the GUI-clients... yes
> checking for tclsh... /usr/bin/tclsh8.5
> checking for wish... /usr/bin/wish8.5
> checking checking for Tcl attribute seperator... .
> checking whether to enable tcl-qstat... yes
> configure: Finished Tcl/Tk configuration
> .
> .
> .
> Building components: server=yes mom=yes clients=yes
>                      gui=yes drmaa=no pam=no
> PBS Machine type: linux
> Remote copy: /usr/bin/scp -rpB
> PBS home: /var/spool/torque
> Default server: serverhost
> Unix Domain sockets: no
> Tcl: -L/usr/lib64 -ltcl8.5 -ldl -lieee -lm
> Tk: -L/usr/lib64 -ltk8.5 -L/usr/lib64 -lX11 -lXss -lXext -L/usr/lib64 -ltcl8.5 -ldl -lieee -lm
> 
> Ready for 'make'.
> --------
> 
> I do notice that your packages are a bit out of date. These are the latest:
> 
> % rpm -qa | egrep '^t(cl|k)-'
> tcl-8.5.5-2.81
> tk-8.5.5-3.14.1
> tcl-devel-8.5.5-2.81
> tk-devel-8.5.5-3.14.1
> 
> Perhaps you are hitting a bug in the packages you have. Otherwise, I'd
> posit that something has gone awry on your system in in your environment.
> 
> HTH,
> 
> Gabe

Hi Albino

Sorry, it didn't help.
I don't have any SLES machine to try.
On CentOS 5.2 and 5.4 and on various Fedora releases
I have no problem whatsoever with the Torque gui.
It installs and works,
as long as the tcl and tk packages and devel packages are installed.

Gus Correa


More information about the torqueusers mailing list