[torqueusers] enable-gui problem on SLES11-SP1

Gus Correa gus at ldeo.columbia.edu
Tue Sep 6 15:34:56 MDT 2011


Hi Albino

Do you need perhaps the 64-bit Tcl/Tk packages, instead of 32-bit?
Since configure is looking for Tcl/Tk items in /usr/lib64,
I guess your machine is 64-bit, right?
Anyway, just a guess.

I hope it helps,
Gus Correa

Albino A. Aveleda wrote:
> Hi All,
> 
> I am trying to compile torque-2.5.8 with --enable-gui option on SLES11-SP1 
> but I always receive the error below. The tcl and tk packages are installed. 
> 
> tcl-32bit-8.5.5-2.81
> tcl-devel-8.5.5-2.81
> tclx-8.4-470.22
> tcl-8.5.5-2.81
> tk-32bit-8.5.5-3.12
> tk-8.5.5-3.12
> tk-devel-8.5.5-3.12
> 
> I have problem with Tk_Init. The error message is below.
> [... skip ...]
> configure: Starting Tcl/Tk configuration
> checking for Tcl configuration... found /usr/lib64/tclConfig.sh
> checking for existence of /usr/lib64/tclConfig.sh... loading
> checking for Tcl public headers... /usr/include
> checking for tclx configuration... none
> checking for Tk configuration... found /usr/lib64/tkConfig.sh
> checking for existence of /usr/lib64/tkConfig.sh... loading
> checking for Tk public headers... /usr/include
> checking for Tcl_Init... yes
> checking for Tk_Init... no
> configure: Your Tk install is broken.  Disabling Tk support.
> checking whether to include the GUI-clients... configure: error: cannot build GUI without Tk library
> 
> How do I fix this?
> 
> Best regards,
> Bibo
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers



More information about the torqueusers mailing list