[torqueusers] 2.5.8 PAM module fails

Ken Nielson knielson at adaptivecomputing.com
Thu Oct 6 15:43:01 MDT 2011


----- Original Message -----
> From: "Ti Leggett" <leggett at mcs.anl.gov>
> To: "Torque Users Mailing List" <torqueusers at supercluster.org>
> Sent: Wednesday, October 5, 2011 7:58:31 AM
> Subject: [torqueusers] 2.5.8 PAM module fails
> 
> I tried upgrading to 2.5.8 from 2.5.7 yesterday and ran into a
> problem with pam_pbssimpleauth:
> 
> Oct  4 15:05:25 c23 sshd[16909]: PAM unable to
> dlopen(/lib64/security/pam_pbssimpleauth.so)
> Oct  4 15:05:25 c23 sshd[16909]: PAM [error:
> /lib64/security/pam_pbssimpleauth.so: undefined symbol:
> getpwnam_ext]
> Oct  4 15:05:25 c23 sshd[16909]: PAM adding faulty module:
> /lib64/security/pam_pbssimpleauth.so
> 
> I built 2.5.8 the same way I built 2.5.7:
> 
> ./configure --host=x86_64-redhat-linux-gnu
> --build=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux
> --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
> --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
> --includedir=/usr/include --libdir=/usr/lib64
> --libexecdir=/usr/libexec --localstatedir=/var
> --sharedstatedir=/usr/com --mandir=/usr/share/man
> --infodir=/usr/share/info --disable-gcc-warnings
> --with-pam=/lib64/security --enable-cpuset
> --enable-geometry-requests --enable-blcr --enable-nvidia-gpus
> 
> Rolling back to 2.5.7 fixed the problem.

I have tried this on CentOS 5 and Ubuntu 11.04 without any problem. I am building from the 2.5-fixes branch in Subversion. Is anyone else having an issue compiling PAM on TORQUE with 2.5.8?

Maybe another good question is "is anyone using PAM with 2.5.8"?

Regards
Ken Nielson
Adaptive Computing


More information about the torqueusers mailing list