[torqueusers] procs= not working as documented

Lance Westerhoff lance at quantumbioinc.com
Thu Nov 17 15:47:31 MST 2011


Hello All-

It appears that when running with the following specs, the procs= option does not actually work as expected.

==========================================

#PBS -S /bin/bash
#PBS -l procs=60
#PBS -l pmem=700mb
#PBS -l walltime=744:00:00
#PBS -j oe
#PBS -q batch

torque version: tried 3.0.2. in v2.5.4, I think the procs option worked as documented
maui version: 3.2.6p21 (also tried maui 3.3.1 but it is a complete fail in terms of the procs option and it only asks for a single CPU)

==========================================

If there are fewer then 60 processors available in the cluster (in this case there were 53 available) the job will go in an take whatever is left instead of waiting for all 60 processors to free up. Any thoughts as to why this might be happening? Sometimes it doesn't really matter and 53 would be almost as good as 60, however if only 2 processors are available and the user asks for 60, I would hate for him to go in.

Thank you for your time!

-Lance




More information about the torqueusers mailing list