[torqueusers] bad resources_used.walltime and Walltime.Remaining

Kenneth Yoshimoto kenneth at sdsc.edu
Mon Mar 28 10:11:29 MDT 2011


resources_used.walltime and Walltime.Remaining seem
inconsistent with start_time and the current date.
This job did have down nodes that came back, so
maybe that would trigger this...

This job was never suspended, so walltime used
should be now - start_time.  walltime remaining
should be Resource_List.walltime - walltime used.
Both resources_used.walltime and Walltime.Remaining
appear to be wrong.

$ qstat -f 17891; date
Job Id: 17891.
...
     resources_used.cput = 00:26:38
     resources_used.mem = 65235940kb
     resources_used.vmem = 81275644kb
     resources_used.walltime = 00:06:59
     job_state = R
     queue = normal
     ctime = Sun Mar 27 09:12:01 2011
     Hold_Types = n
     interactive = True
     Join_Path = n
     Keep_Files = n
     Mail_Points = a
     mtime = Sun Mar 27 09:12:53 2011
     Output_Path = /dev/pts/0
     Priority = 0
     qtime = Sun Mar 27 09:12:01 2011
     Rerunable = False
     Resource_List.nodect = 2
     Resource_List.nodes = 2:ppn=8:exclusive
     Resource_List.walltime = 05:00:00
     session_id = 15100
     comment = Catalina job start time (1301242332)
     etime = Sun Mar 27 09:12:01 2011
     submit_args = -I -A XXXXXX -l nodes=2:ppn=8:exclusive -q normal -v QOS=0 -
         l walltime=05:00:00
     start_time = Sun Mar 27 09:12:12 2011
     Walltime.Remaining = -6780
     start_count = 1
     fault_tolerant = False

Mon Mar 28 09:02:20 PDT 2011


More information about the torqueusers mailing list