[torqueusers] Question about RPM SPEC

Albino A. Aveleda bino at coc.ufrj.br
Thu Aug 4 10:29:10 MDT 2011

Hi All,

On torque-2.5.7, I would like to understand why the torque.spec 
create a torque-client (obsolete name torque-mom) with dependece 
the torque-2.5.7 that has all commands like qstat, qsub etc. It 
doesn´t make sense because the compute nodes don´t need the 
client commands. I suggest creating a torque-lib with theses libs. 

You can see below the dependecies.

# rpm -ivh torque-client-2.5.7-1.nacad.x86_64.rpm 
error: Failed dependencies:
        torque = 2.5.7-1.cri is needed by torque-client-2.5.7-1.cri.x86_64
        libtorque.so.2()(64bit) is needed by torque-client-2.5.7-1.cri.x86_64

# rpm -qlp torque-2.5.7-1.cri.x86_64.rpm 

Best regards,

More information about the torqueusers mailing list