[torqueusers] pbs_mom process owned by non-root user

"Mgr. Šimon Tóth" SimonT at mail.muni.cz
Wed Oct 6 04:20:08 MDT 2010


> We're seeing a strange problem with our cluster where nodes are marked off line and, on further investigation, we see that the pbs_mom process has become owned by a normal user. The user has run a job on the node which, as far as we can see, does nothing strange - just copies files to $TMPDIR, runs a perl script and copies output back from $TMPDIR to user's home directory. There's nothing in the perl script itself which looks odd either.
> 
> It's not a new pbs_mom process started by the user (which fails correctly if tried) rather a process started by init which has then had its ownership changed. This is only happening for one specific user and does happen on multiple nodes but we can see no obvious cause.
> 
> The version of Torque is 2.5.2.
> 
> We'd appreciate any suggestions on the likely cause of this especially if anyone else has seen similar behaviour.

Are you sure that the pbs_mom you see running isn't the forked process
that is actually supposed to run with user privs and the actual pbs_mom
running as root crashed?

-- 
Mgr. Šimon Tóth

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3366 bytes
Desc: S/MIME Cryptographic Signature
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20101006/0404681f/attachment-0001.bin 


More information about the torqueusers mailing list