[torqueusers] Script problem (can't find executable)

Kevin Van Workum vanw at sabalcore.com
Thu Nov 11 06:50:46 MST 2010


On Thu, Nov 11, 2010 at 6:42 AM, Guille <guillermo.marco at gmail.com> wrote:

> Hi guys i've made a PBS script to launch another program called "tophat"
>
> tophat is located at /usr/local/bin/tophat
>
> Here's my pbs script located in /home/PBS_scripts/
>
> #!/bin/sh
> #PBS -l walltime=00:05:00
> #PBS -N tophat_script
> #PBS -o tophat_script.out
> #PBS -e tophat_scriptb.err
>
> echo Script starts..
> cd /usr/local/bin/
> ./tophat -r 150 /data/results/Sl65/reference_genome/GRch37.58/hg19 1_1.fa
> 1_2.fa
> echo Script ends..
>
> This job script never uses any node or procesor, (1 node and 1 procesor by
> default) and apears in queue as "C" state.
>
> The tophat_scriptb.err looks like this:
>
> /opt/torque/mom_priv/jobs/22825.sistemas-genom8.sistemas.local.SC: line 9:
> ./tophat: No such file or directory
>
> How the hell i can specify the path to my script location because i've
> tried doing cd like the script above and using PBS_O_PATH but nothing seems
> to work..
>
> Thanks for help :)
>

Perhaps 'tophat' is on your submitting machine only, and not on your
execution node?


>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>


-- 
Kevin Van Workum, PhD
Sabalcore Computing Inc.
Run your code on 500 processors.
Sign up for a free trial account.
www.sabalcore.com
877-492-8027 ext. 11
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20101111/85d0fcbd/attachment.html 


More information about the torqueusers mailing list