[torqueusers] Problems compiling Torque GSSAPI branch

Mike Coyne Mike.Coyne at PACCAR.com
Tue Mar 9 06:26:08 MST 2010


You might try to add a 
#define A_(x) x 
To get rid of it to your src/include/pbs_config.h and pbs_config.h.in 
Or just edit out the A_(...)  it's a  carry over from the original
torque gssapi version that did not get fixed when it was updated to the
2.4 code level ...
Mine looks more like this


/* the following routines set/control DIS over tcp */

extern void DIS_tcp_reset (int fd, int rw);
extern void DIS_tcp_setup (int fd);
extern int  DIS_tcp_wflush (int fd);
extern void DIS_tcp_settimeout (long timeout);
extern int  DIS_tcp_istimeout (int fd);
extern void DIS_tcp_release (int fd);
#ifdef GSSAPI
extern void DIS_tcp_set_gss (int fd, gss_ctx_id_t ctx, OM_uint32 flags);
#endif


extern int  PConnTimeout(int);

-----Original Message-----
From: torqueusers-bounces at supercluster.org
[mailto:torqueusers-bounces at supercluster.org] On Behalf Of Peter Smith
Sent: Monday, March 08, 2010 6:54 PM
To: torqueusers at supercluster.org
Subject: [torqueusers] Problems compiling Torque GSSAPI branch

Hi

I am trying to compile the GSSAPI branch of Torque on a Debian Lenny
system.

I run configure with the following options:

./configure --with-default-server=cluster-master
--with-server-home=/var/spool/pbs --with-rcp=scp --with-gssapi
--disable-unixsockets

No errors are returned and the last string is "Ready for 'make'"

Then i run make and 2-3 seconds and the following error messages is
shown:

../../../src/include/dis.h:250: error: expected '=', ',', ';', 'asm'
or '__attribute__' before 'A_'
make[3]: *** [dis.lo] Error 1
make[3]: Leaving directory `/shared/source/gssapi/src/lib/Libpbs'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/shared/source/gssapi/src/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/shared/source/gssapi/src'
make: *** [all-recursive] Error 1

If i run configure without the --with-gssapi and --disable-unixsockets
options, exactly the same error message is shown so this makes no
difference. On the same system if i try to download
torque-2.4.6.tar.gz this package compile and installes fine without
errors.

This is a couple of lines from dis.h, the line numbers is added by me:

249: extern int  DIS_tcp_istimeout (int fd);
250: extern void DIS_tcp_release A_((int fd));
251: #ifdef GSSAPI
252: extern void DIS_tcp_set_gss A_((int fd, gss_ctx_id_t ctx,
OM_uint32 flags));
253: #endif

Does anybody have a suggestion on how i can solve this problem, i
would really like to get this working.
_______________________________________________
torqueusers mailing list
torqueusers at supercluster.org
http://www.supercluster.org/mailman/listinfo/torqueusers




More information about the torqueusers mailing list