[torqueusers] Problems compiling Torque GSSAPI branch

Peter Smith peter.smith3882100 at gmail.com
Mon Mar 8 17:54:15 MST 2010


Hi

I am trying to compile the GSSAPI branch of Torque on a Debian Lenny system.

I run configure with the following options:

./configure --with-default-server=cluster-master
--with-server-home=/var/spool/pbs --with-rcp=scp --with-gssapi
--disable-unixsockets

No errors are returned and the last string is "Ready for 'make'"

Then i run make and 2-3 seconds and the following error messages is shown:

../../../src/include/dis.h:250: error: expected '=', ',', ';', 'asm'
or '__attribute__' before 'A_'
make[3]: *** [dis.lo] Error 1
make[3]: Leaving directory `/shared/source/gssapi/src/lib/Libpbs'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/shared/source/gssapi/src/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/shared/source/gssapi/src'
make: *** [all-recursive] Error 1

If i run configure without the --with-gssapi and --disable-unixsockets
options, exactly the same error message is shown so this makes no
difference. On the same system if i try to download
torque-2.4.6.tar.gz this package compile and installes fine without
errors.

This is a couple of lines from dis.h, the line numbers is added by me:

249: extern int  DIS_tcp_istimeout (int fd);
250: extern void DIS_tcp_release A_((int fd));
251: #ifdef GSSAPI
252: extern void DIS_tcp_set_gss A_((int fd, gss_ctx_id_t ctx,
OM_uint32 flags));
253: #endif

Does anybody have a suggestion on how i can solve this problem, i
would really like to get this working.


More information about the torqueusers mailing list