[torqueusers] torque-2.4.6 compilation problem

Albino A. Aveleda bino at coc.ufrj.br
Wed Mar 3 06:27:17 MST 2010



Hi All, 



I have a Altix 450 with SLES 11 and I tried to compile the torque-2.4.6 with 
this parameters. 
./configure --prefix=/usr/local/torque --enable-server --enable-mom --enable-clients \ 

  --enable-docs --enable-syslog --with-server-home=/var/spool/torque --enable-cpuset 

After the compilation I received the follow error . 
... 
gcc -g -O2 -D_LARGEFILE64_SOURCE -W -Wall -Wno-unused-parameter -Wno-long-long -pedantic -Werror -DUSEJOBCREATE -o .libs/pbs_mom catch_child.o mom_comm.o mom_inter.o mom_main.o mom_server.o prolog.o requests.o start_exec.o checkpoint.o tmsock_recov.o req_quejob.o job_func.o attr_recov.o dis_read.o job_attr_def.o job_recov.o process_request.o reply_send.o resc_def_all.o job_qs_upgrade.o  linux/libmommach.a -L/opt/cray/job/default/lib64 /usr/lib/libjob.so -lcap -lpam -lutil ../lib/Libattr/libattr.a ../lib/Libsite/libsite.a ../lib/Libutils/libutils.a ../lib/Libpbs/.libs/libtorque.so  -Wl,--rpath -Wl,/usr/local/torque/lib 
/usr/lib/gcc/ia64-suse-linux/4.3/../../../../ia64-suse-linux/bin/ld: cannot find -lcap 
collect2: ld returned 1 exit status 
make[3]: *** [pbs_mom] Error 1 
make[3]: Leaving directory `/usr/local/src/torque/torque-2.4.6/src/resmom' 
make[2]: *** [all-recursive] Error 1 
make[2]: Leaving directory `/usr/local/src/torque/torque-2.4.6/src/resmom' 
make[1]: *** [all-recursive] Error 1 
make[1]: Leaving directory `/usr/local/src/torque/torque-2.4.6/src' 
make: *** [all-recursive] Error 1 


Then, I tried to compile the torque-2.3.10 with same parameters and I didn´t have any error. 

Is torque-2.4.x a beta release? 



Best regards, 
Bibo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20100303/ac3a68d0/attachment.html 


More information about the torqueusers mailing list