[torqueusers] Interactive job issue

Kevin Van Workum vanw at sabalcore.com
Tue Mar 2 08:56:03 MST 2010


On Sun, Feb 28, 2010 at 8:42 AM, Prakash Velayutham <
prakash.velayutham at cchmc.org> wrote:

> Hi,
>
> I have an application that disconnects itself from the parent and
> makes init as its parent process during startup.
>
> I have modified torque's source so I am able to submit batch scripts
> to interactive jobs too (--enable-shel-use-argv during compilation and
> some changes to qsub.c), but this particular job is killed by MOM as
> soon as it starts because MOM finds the application to have completed
> when it changes its parent process to init and kills it.
>
> I am planning on starting a different process in the same batch job
> that will keep spinning until the original application actually quits.
> Just wanted to know from other torque admins if this is the right way
> to go about solving this.
>
> Torque - 2.3.6
>
> Thanks,
> Prakash
>

I've solved similar issues by wrapping it in an Expect script. But your
method sounds simple and effective.


> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>



-- 
Kevin Van Workum, PhD
Sabalcore Computing Inc.
Run your code on 500 processors.
Sign up for a free trial account.
www.sabalcore.com
877-492-8027 ext. 11
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20100302/80874ecb/attachment.html 


More information about the torqueusers mailing list