[torqueusers] trying to compile gssapi branch, autoconf error

Andreas Davour davour at pdc.kth.se
Tue Jun 29 09:00:54 MDT 2010


I'm getting some odd results when running configure. 

It looks like there is a work-around mentioned in the autoconf manual, but I 
know far to little of m4 to try to add that "fourth argument" 
(http://www.gnu.org/software/hello/manual/autoconf/Present-But-Cannot-Be-
Compiled.html).

Anyone know how to fix that?

I run autoconf 2.59 and it looks like that is the newest there is for CentOS.

This is my command line:
./configure --disable-unixsockets --with-gssapi=/usr/heimdal --with-
rcp=/usr/heimdal/bin/rcp  --disable-gcc-warnings CPPFLAGS=-
I/usr/openafs/include 

This is the configure output, with the error:

checking for krb5-config... /usr/heimdal/bin/krb5-config
checking for gssapi support... yes
checking whether we are using Heimdal... yes
checking gssapi.h usability... yes
checking gssapi.h presence... yes
checking for gssapi.h... yes
checking gssapi/gssapi.h usability... yes
checking gssapi/gssapi.h presence... yes
checking for gssapi/gssapi.h... yes
checking gssapi_krb5.h usability... no
checking gssapi_krb5.h presence... no
checking for gssapi_krb5.h... no
checking gssapi/gssapi_krb5.h usability... yes
checking gssapi/gssapi_krb5.h presence... yes
checking for gssapi/gssapi_krb5.h... yes
checking gssapi_generic.h usability... no
checking gssapi_generic.h presence... no
checking for gssapi_generic.h... no
checking gssapi/gssapi_generic.h usability... no
checking gssapi/gssapi_generic.h presence... yes
configure: WARNING: gssapi/gssapi_generic.h: present but cannot be compiled
configure: WARNING: gssapi/gssapi_generic.h:     check for missing prerequisite 
headers?
configure: WARNING: gssapi/gssapi_generic.h: see the Autoconf documentation
configure: WARNING: gssapi/gssapi_generic.h:     section "Present But Cannot Be 
Compiled"
configure: WARNING: gssapi/gssapi_generic.h: proceeding with the preprocessor's 
result
configure: WARNING: gssapi/gssapi_generic.h: in the future, the compiler will 
take precedence
configure: WARNING:     ## ------------------------------------------- ##
configure: WARNING:     ## Report this to torqueusers at supercluster.org ##
configure: WARNING:     ## ------------------------------------------- ##
checking for gssapi/gssapi_generic.h... yes
checking afs/param.h usability... yes
checking afs/param.h presence... yes
checking for afs/param.h... yes
checking for libafsauthent... checking for setpag in -lafsauthent_pic... no
configure: WARNING: Can't find libafsauthent
checking for kdestroy... /usr/heimdal/bin/kdestroy
checking for kinit... kinit
checking for aklog... no


-- 
Systems Engineer
PDC Center for High Performance Computing
CSC School of Computer Science and Communication
KTH Royal Institute of Technology
SE-100 44 Stockholm, Sweden
Phone: 087906658
"A satellite, an earring, and a dust bunny are what made America great!"


More information about the torqueusers mailing list