[torqueusers] Torque 2.5.2-snapshot - Cygwin Version

Yauheni Charniauski cherniavsky at newman.bas-net.by
Tue Jul 27 16:28:26 MDT 2010


Здравствуйте, Felix.

Вы писали 27 июля 2010 г., 10:03:42:

> Dear Igor,

> I've just installed the Torque 2.5.2 -snapshot version from the
> download page and tried to install and test it on my Windows XP x64
> machine. Before installing the new software I did a "make uninstall"
> on the old one. I followed exactly your documentation README.cygwin
> and this time it worked without problems on my machine. I no longer
> get the message I got before (that the shell could not be executed).
> I did not need the LSA registry feature of Cygwin. A test job runs fine. Amazing :-)!

> Now for another problem ;-): The main application which I would
> like to run under the control of Torque is a GUI application, i.e.,
> it will open a graphical user interface and there is no way to
> prevent this. If it is running on Linux it just opens its GUI on the
> virtual X server (Xvfb). However, as this mechanism does not exist
> on Windows the program just gets stuck (I guess it gets stuck in the
> moment where it tries to open its GUI). I know that, e.g., the LSF
> resource management system is able to use the Microsoft Terminal
> Services for this type of applications. You can then even connect to
> the session your job is running in via the RDP client (tspeek
> command) and see the GUI of your program which is quite convenient
> for a user as he can directly see the progress of his job. The
> following link points to the website where the LSF guys explain how
> to set this up with LSF:
> http://ams.cern.ch/AMS/7/lsf_windows_using/msts.html

> Do you see any chance that something similar is possible with
> Torque? Otherwise I'm getting stuck here as this application is more
> or less the only one which should run under the DRM and I'm not an
> expert (yet) in Windows Terminal Services. However, if you see any
> chance to get this working I'm willing to invest some time to become
> an expert in the Terminal Services thing ;-).

> Thanks for your help!

> Best regards

> Felix Wolfheimer


Hello Felix Wolfheimer

At the current moment RDP protocol is not supported by Torque. if you want to release it you need to do much work.
We are not planning do this job for future.
You can try to build and to run your application under Windows using X-Server http://x.cygwin.com/ as well as under Linux.

------
Yauheni Charniauski

United Institute of Information Problems NAS of Belarus
http://uiip.bas-net.by



More information about the torqueusers mailing list