[torqueusers] location of pam module

Lloyd Brown lloyd_brown at byu.edu
Wed Dec 15 08:17:30 MST 2010


On 12/14/10 6:16 PM, Michael Jennings wrote:
> What is the output of the following commands?
>
> rpm --showrc | fgrep _lib
> rpm -q --qf '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n' -f /lib/security/pam_pbssimpleauth.so
>

The host I built the RPMs on doesn't actually have it installed, so the
second command fails.  I'll include the output of the first command from
the compilation host, and the second from a sample host where the RPM is
installed.

> [root at m6 ~]# rpm --showrc | fgrep _lib
>         %{__libtoolize} --force --copy;
>   %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform}
> --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir}
> --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir}
> --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir}
> --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir}
> --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir}
> --infodir=%{_infodir} %* ;
> PKG_CONFIG_PATH="%{_libdir}/pkgconfig:%{_datadir}/pkgconfig"
> -14: __libtoolize       libtoolize
> -14: __mono_provides    /usr/lib/rpm/mono-find-provides
> %{_builddir}/%{?buildsubdir} %{buildroot} %{_libdir}
> -14: __mono_requires    /usr/lib/rpm/mono-find-requires
> %{_builddir}/%{?buildsubdir} %{buildroot} %{_libdir}
> -14: _lib       lib64
> -14: _libdir    %{_exec_prefix}/%{_lib}
> -14: _libexecdir        %{_exec_prefix}/libexec
> -14: _multilibpatt     
> (/%{_lib}|/usr/%{_lib}(|/gconv)|/usr/local/%{_lib}|/usr/X11R6/%{_lib}|/opt/%{_lib})/[^/]*\.([oa]|la|so[0-9.]*)$
>         --libdir=%{_libdir} \
>         --libexecdir=%{_libexecdir} \
>         libdir=%{?buildroot:%{buildroot}}%{_libdir} \
>         libexecdir=%{?buildroot:%{buildroot}}%{_libexecdir} \




> [root at m6-1-1 ~]# rpm -q --qf '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n'
> -f /lib/security/pam_pbssimpleauth.so
> torque-pam-2.4.7.8901patch-1cri.x86_64


Note that, as I said before, this is slightly patched, and so the
version number was adjusted.  This was support ticket 8901, so I called
it "2.4.7.8901patch".



Thanks for your help,

Lloyd


-- 


Lloyd Brown
Systems Administrator
Fulton Supercomputing Lab
Brigham Young University
http://marylou.byu.edu




More information about the torqueusers mailing list