[torqueusers] number of nodes problem - SOLVED

Kirill Belyaev kira at cfd.spbstu.ru
Thu Oct 15 01:06:35 MDT 2009


Hi,

I posted a problem a week ago, but I have solved it already.
The cause of this problem - I made rpm and used install torque using 
them. When I installed from source (make, make install), the things 
started to work well.

Below is description of my problem. May be it helps someone.

Best regards,
Kirill.

--------------------------------------------------------------------

I have installed torque 2.3.7 on OpenSUSE 11.1 x86 (I want to use it 
with OpenMPI). I have one pbs server (comp24) and several nodes 
(comp2-23), scheduling is pbs_sched.
All looks fine except one problem:

This is my job file is:

--------------------------
#!/bin/sh
#PBS -j oe
#PBS -o test.log
#PBS -l nodes=8

sleep 10
echo `cat $PBS_NODEFILE`
--------------------------

The result of this job is:

----------------------------
comp2
----------------------------

qstat -f:

----------------------------
...
     Resource_List.neednodes = 8
     Resource_List.nodect = 8
     Resource_List.nodes = 8
...
----------------------------

pbsnodes says that state is job-exclusive only for one node 'comp2'.
All other nodes is free.

Why it give me only one node when I requested 8?
What I should do to get all 8 nodes?



More information about the torqueusers mailing list