[torqueusers] Torque problem

Smith, Jerry Don II jdsmit at sandia.gov
Tue Nov 17 08:09:24 MST 2009


Do you declare a shell at the beginning of the script?

#!/bin/bash
#PBS ...

Jerry

________________________________
From: torqueusers-bounces at supercluster.org <torqueusers-bounces at supercluster.org>
To: torqueusers at supercluster.org <torqueusers at supercluster.org>
Sent: Tue Nov 17 03:52:50 2009
Subject: [torqueusers] Torque problem


Hi,

I'm working with a Linux Cluster(RH5.2) with one manager server (name mgmt001_c) and 128 nodes.We have TORQUE 2.3-
I created one user(name eolo,id eolo uid=1000(eolo) gid=1000(eolo) groups=1000(eolo)),queue (name colaupv) and shell script (name cola2)


QUEUE

$ qmgr -c 'p s'
#
# Create queues and set their attributes.
#
# Create and define queue colaupv
#
create queue colaupv
set queue colaupv queue_type = Execution
set queue colaupv acl_user_enable = True
set queue colaupv acl_users = eolo
set queue colaupv enabled = True
set queue colaupv started = True
#
# Set server attributes.
#
set server scheduling = True
set server acl_hosts = mgmt001_c
set server managers = root at mgmt001_c<mailto:root at mgmt001_c>
set server operators = root at mgmt001_c<mailto:root at mgmt001_c>
set server default_queue = batch
set server log_events = 511
set server mail_from = adm
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server log_level = 3
set server mom_job_sync = True
set server keep_completed = 300
set server next_job_number = 289

COLA2 SCRIPT

$ more cola2
#PBS -S /usr/bin/bash
#PBS -l nodes=1,mem=32gb,walltime=240:00:00

source ~/.bashrc
echo 'unai' > /Gdata/home/eolo/DINEOF_3.0/1_0_2008/salida_echo.txt



The problem is the next:

I try to submit a job,it appears as "COMPLETE STATE" when i run "qstat" but the job doesn't run anything.


$ qsub -q colaupv cola2
289.mgmt001_c
$ qstat
Job id                    Name             User            Time Use S Queue
------------------------- ---------------- --------------- -------- - -----
289.mgmt001_c             cola2            eolo            00:00:00 C colaupv

The salida_echo.txt doesn't exist and i don't know why the job has "C State" .

In 5minutes the job desappears in the qstat-

Anyway,I think that the job is submitting in the manager(mgmt001_c) instead of the nodes.

I need help to resolve this problem
Any suggestion???????.

Many thanks in advance.

Regards


[cid:_1_0752D6F40752D068003C4AD6C1257671]
------------------------------------------------------------------------------------------------------------------------------------
Este mensaje va dirigido únicamente a la(s) persona(s) y/o entidad(es) arriba relacionada(s).
Puede contener información confidencial o legalmente protegida. Si no es usted el destinatario
señalado, le rogamos borre del sistema inmediatamente el mensaje y sus copias. Asimismo le
informamos que cualquier copia, divulgación, distribución o uso de los contenidos está
prohibida.
------------------------------------------------------------------------------------------------------------------------------------

Ingeniería de Software Avanzado, S.A. Domicilio Social: Avda. de Burgos 8-A 28036 de Madrid.
telf: 913834060, Fax: 913834090. Reg. M. Madrid: Tomo 3238, Libro:0, Folio: 78, Seccion: 8ª,
Hoja M-55112, N.I.F.: A-80157746
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20091117/0673ca6f/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ATT00003.gif
Type: image/gif
Size: 5205 bytes
Desc: ATT00003.gif
Url : http://www.supercluster.org/pipermail/torqueusers/attachments/20091117/0673ca6f/attachment-0001.gif 


More information about the torqueusers mailing list