[torqueusers] No access to host directory

Andrew Kelley apkelley at princeton.edu
Thu Nov 5 12:57:06 MST 2009


Hello,

 

I am very new to using linux and extremely new to torque, so please excuse
me if this is a simple problem, but I can't find any solutions online.  

 

I can't seem to get access to the files that I have stored on the directory
where I run the command qsub when I'm using a shell script.  For instance,
if I run the command

 

mkdir newdirectory | qsub

 

A new directory called newdirectory is created in the current working
directory where I ran the command on the submit server.  However, if I
instead write a script called example.sh:

 

#!/bin/sh

#

#PBS -N examplescript

#PBS -l nodes=1,walltime=00:01:00

#PBS -q batch

mkdir newdirectory

 

The new directory is created on the node that Torque uses, but the directory
never appears on the server where I submitted the job.  

 

Am I misunderstanding the way that I should be writing the shell script or
is there something wrong with my settings?  I would greatly appreciate any
help and apologize if this is a stupid question.

 

Thanks,

Andrew

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20091105/b94c4ec0/attachment.html 


More information about the torqueusers mailing list