[torqueusers] Problem about $PBS_NODEFILE

Glen Beane glen.beane at gmail.com
Thu Mar 19 06:38:56 MDT 2009


you need to tell torque how many nodes/processors the job requires
using qsub -l or #PBS -l (small L)


qsub -l nodes=3D3:ppn=3DX ... (where X is the number of processors on each
of your nodes, e.g. 1,2,4,8)?

or you can and #PBS -l nodes=3D3:ppn=3DX to your job script.





2009/3/19 tracy_luofengji <tracy_luofengji at 126.com>:
> Dear all,
>
> I have installed torque-2.3.0 on 4 machines:1 master and 3 slaves. When I
> start the pbs_mom of the slave machines and use "pbsnodes -a" to check th=
eir
> status, the result is correct: 3 machines are list and the status of all =
the
> 3 machines are "free".
>
> But if I submit a job script on the master to check the $PBS_NODEFILE, as
> following:
> #!/bin/tcsh
> #PBS -o /usr/local/out
> #PBS -e /usr/local/err
> cd $PBS_O_WORKDIR
> cat $PBS_NODEFILE
>
> And then I used "vim /usr/local/out" to check the output, found that ther=
e
> was only 1 node (the first slave node) displayed in the output file. Why?
>
> Any help will be appraciated
> Thanks!
>
> Regards,
> Tracy
>
>
>
> ________________________________
> =CD=F8=D2=D7=D3=CA=CF=E4=A3=AC=D6=D0=B9=FA=B5=DA=D2=BB=B4=F3=B5=E7=D7=D3=
=D3=CA=BC=FE=B7=FE=CE=F1=C9=CC
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>


More information about the torqueusers mailing list