[torqueusers] two queues for torque server and maui scheduler

Zerony Zhao bw.linux at gmail.com
Mon Jun 15 09:14:56 MDT 2009


Garrick, Steve and Torque users,

Sorry for responding late, I was out of town for several days. Thank you for
help.

Here is the output of qmgr -c 'p s'.

#
# Create queues and set their attributes.
#
#
# Create and define queue core2
#
create queue core2
set queue core2 queue_type = Execution
set queue core2 acl_host_enable = False
set queue core2 acl_hosts = core01
set queue core2 resources_default.neednodes = core2
set queue core2 resources_default.walltime = 1000:00:00
set queue core2 enabled = True
set queue core2 started = True
#
# Create and define queue opteron
#
create queue opteron
set queue opteron queue_type = Execution
set queue opteron acl_host_enable = False
set queue opteron acl_hosts = opteron01
set queue opteron resources_default.neednodes = opteron
set queue opteron resources_default.walltime = 1000:00:00
set queue opteron enabled = True
set queue opteron started = True
#
# Set server attributes.
#
set server scheduling = True
set server acl_hosts = master
set server managers = root at master
set server operators = root at master
set server default_queue = core2
set server log_events = 511
set server mail_from = adm
set server resources_default.nodes = 1
set server resources_default.walltime = 1000:00:00
set server scheduler_iteration = 600
set server node_check_rate = 150
set server tcp_timeout = 6
set server node_pack = False
set server auto_node_np = True
set server next_job_number = 219

The test pbs script is:

#PBS -S /bin/tcsh
#PBS -q opteron

hostname >> host
sleep 30

Is there any problems, do I need use routine queue? Thanks.

ZZ

On Tue, Jun 9, 2009 at 2:08 AM, Garrick <garrick at usc.edu> wrote:

> Can we see the output of 'p s' in qmqr?
>
> HPCC/Linux Systems Admin
>
> On Jun 8, 2009, at 1:38 PM, Zerony Zhao <bw.linux at gmail.com> wrote:
>
> Dear torque users,
>
> A naive question again. Now I created two queues successfully, each queue
> will only access the specified nodes, the two queues' name are slownode and
> fastnode. I specified the queue name in pbs script,
>
> #PBS -q slownode
> or
> #PBS -q fastnode
>
> But the jobs always go to the default queue, instead of the specified
> queue. I can't figure out what the problem is, could you help me?
>
> Thank you in advance,
>
> ZZ
>
> _______________________________________________
> torqueusers mailing list
> torqueusers at supercluster.org
> http://www.supercluster.org/mailman/listinfo/torqueusers
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20090615/62e17f35/attachment.html 


More information about the torqueusers mailing list