[torqueusers] Generic resources not working in 2.3.6 ?

Kamil Kisiel kamil at zymeworks.com
Wed Jan 14 17:47:10 MST 2009


Previously we were running 2.1.x on our cluster and our moms were configured
with the following generic resource:

Image_version !/usr/bin/cat /VERSION

The file /VERSION contains the version string for our node image. We were
able to extract this information from the generic resources in our
monitoring script and see which nodes run which version of the image. After
upgrading to 2.3.6 this week this no long works.

I¹ve also tried setting $configversion as a possible alternative, but it
seems that value is not reported by pbsnodes either.

I know our previous usage was a slight abuse of the intent of generic
resources, but it worked as far as getting information from a node
dynamically goes. Any ideas what could be wrong, or suggestions on an
alternate implementation?

- Kamil


Notice of Confidentiality: The information transmitted is intended only for the
person or entity to which it is addressed and may contain confidential and/or
privileged material. Any review, re-transmission, dissemination or other use of
or taking of any action in reliance upon this information by persons or entities
other than the intended recipient is prohibited. If you received this in error
please contact the sender immediately by return electronic transmission and then
immediately delete this transmission including all attachments without copying,
distributing or disclosing the same.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.supercluster.org/pipermail/torqueusers/attachments/20090114/32940046/attachment.html


More information about the torqueusers mailing list