[torqueusers] Hanging TIME_WAIT

Tim Freeman tfreeman at mcs.anl.gov
Wed Feb 18 13:37:40 MST 2009


On Tue, 17 Feb 2009 21:56:52 -0700 (MST)
Josh Butikofer <josh at clusterresources.com> wrote:

> Tim,
> 
> > Josh, thankyou for responding and thankyou for the suggestion.
> 
> No problem.
>  
> > This is on a private VM based cluster with its own LAN so the security
> > issue
> > doesn't really apply.
> > 
> > I went ahead and tried --disable-privports out but got this error
> > (works fine
> > when configure is run without it, I also tried make clean, etc.).
> 
> Some compiler warnings are preventing it from fully compiling. Add
> "--disable-gcc-warnings" to the configure arguments as well and you should
> get better results.

Well, that compiles and installs but now Torque does not function anymore.

Getting "15056 Bad DIS based Request Protocol" errors in the logs when running
qmgr and qsub.


$ echo "hostname" | qsub
qsub: Invalid request MSG=no job owner specified


$ qmgr -c "print server"

#
# Create queues and set their attributes.
#
#
# Create and define queue defaultq
#
create queue defaultq
set queue defaultq queue_type = Route
set queue defaultq route_destinations = batchq
set queue defaultq enabled = True
set queue defaultq started = True
#
# Create and define queue batchq
#
create queue batchq
set queue batchq queue_type = Execution
set queue batchq enabled = True
set queue batchq started = True
qmgr obj= svr=default: Bad DIS based Request Protocol MSG=cannot decode message



More information about the torqueusers mailing list