[torqueusers] Trouble with prologue script

Joshua Bernstein jbernstein at penguincomputing.com
Mon Feb 9 15:46:28 MST 2009



Tim Miller wrote:
> Hi Joshua,
> 
> Thanks for the reply.
> 
> I've tried the script with and without an explicit exit 0 with the 
> results are the same. I've also tried just running the script myself 
> from the command line, and verifying that the exit code is 0. FWIW, the 
> script is a Bourne shell script -- maybe I should try something 
> different like Perl or Python?

Hmmm. I use Bourne shell scripts all day long. I can't imagine that just 
changing the interpriter will fix anything.

Does the script contain the magic key at the top so that TORQUE knows how to 
process the script? You know something like:

#!/bin/bash
echo "-=== Hello from Prologue ===-"

When writing simple test scripts I've often found I forget the silly little #! 
at the beginning. Especially when I'm in a hurry.

The exit code of 255 sounds like its coming from a shell and not from TORQUE. 
The docs are pretty explicit about the types of errors TORQUE returns. Just so 
we're on the same page here, have a look at section G.4 here:

http://www.clusterresources.com/torquedocs21/a.gprologueepilogue.shtml

-Josh


More information about the torqueusers mailing list